Jump to content

Advice on how to proceed fixing inflatable hot tub


Recommended Posts

Good morning,

We got our hot tub out the other week after being away over winter 2 weeks out of warranty and it does not work!  So I have been trying to figure out what the issue is with it.

It is getting an E1 and the model is a mspa tekpro 6. I tried all the obvious things cleaning hosing through the in/out let pipets etc and no look. It runs for several minutes before it gets the error and does it when the filter is on in isolation (i.e. the heater isnt the issue). I have now dismantled it to get to the innards and tried descaling it a couple of times the pump defiantly runs but if I pin open the 2 flow sensors it runs fine without the error so i figure it must be a flow issue.

So my current working assumptions are either:

  • The pump has lost power and isnt powerful enough to hold the flow sensors open, its resistance is less than 2ohms.
  • There is not enough power being put to the pump
  • There is a blockage in the heater unit limiting the flow, when i put mu finger in to the heater it feels rough and like it narrows but i assume this is narrowing as there are multiple runs up and down and the roughness as well is to increase the surface area for heating the water?

I dont think i can really do much more to diagnose the issue with what i have so i think i need to try ordering some parts and replace something. What would your fist guess be as to what the issue is and what to replace first?  Is it heard of for a pump to just loose power rather than giving up completely?

Many thanks


Link to comment
Share on other sites

  • 7 months later...

Hi Sean,

Did you ever manage to fix this - I've got the same hot tub and a similar issue in the fact it runs for a few minutes with simply the filter running and then errors with the E1 error.

We had quite a major flood recently which thankfully didn't quite reach the house, although elevated on decking a good foot and a half above the grass, the water got high enough for the hot tub to be sitting in just short of an inch of water. The circuit breaker was completely submerged and I've replaced that directly from mSpa but I thought the hot tub itself was initially OK.

I've taken the control box apart and checked the filter and although it makes bit of a rattle (it always kinda has) it's clear of dirt.

I was thinking of ordering a replacement filter but wondered if you'd had any success before I shell out £65 on a guess.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...