Jump to content

Search the Community

Showing results for tags 'goplus'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 1 result

  1. Hello, I have a goplus inflatable spa, model PH050017. I purchased it new on eBay several months ago. It has been working great up until now. During the recent hurricane , I drained it and stored it in the garage. In order to move it, I stood it on its side and rolled it from the side yard into our garage. After I set it back up today, everything works except the heater. When I press the temperature button it makes a beeping sound and the display is stuck flashing 68 degrees and won't change when I press the arrow keys. I drained the spa again and flipped it over but there is no
×
×
  • Create New...