Jump to content

Ozziejay

Members
  • Content Count

    12
  • Joined

  • Last visited

Everything posted by Ozziejay

  1. Gave the spa store the model, they can’t even tell me if it has an ozonator?
  2. Agreed, I just like to at least feel like I know what I’m doing...lol
  3. RDspaguy, I appreciate all your advice! Thank you for the help.
  4. This is really frustrating. Can’t trust the pool store advice. Would complaining to the Hot Tub Store accomplish anything? I’ve already drained it twice since March. My only recourse is to purge and drain again?
  5. Goes into a junction(or Union), two ends coming off that go nowhere, a line to the left into the insulation, line to the right down around into the pump
  6. Cover was on, not in sunlight. Did not add any MPS, I have it but have not used for over a week.
  7. 12 hrs after adding chlorine, FC-0, TC-1. Any suggestions?
  8. I added sodium hypochlorite 3hours ago, brought it up to 5ppm. Just tested, Free and Total are both at 5, so CC is 0. I will test again in the morning.
  9. It’s a Mira hot tub, 110 volt. When I went back to the store it was purchased from they looked it up and said it was a Dynasty Spa? I would guess that’s the pump equipment, it was a filter related question.
  10. First time hot tub owner. Just refilled a week ago, FC goes from 2-3ppm when added to zero, PH keeps rising within 24 hours. Pool store found high phosphates in hot tub and tap water. Rinsed filter, adjusted PH, added chlorine (sodium hypochlorite ), then added phosphate remover per directions, which stated 32oz per 10k gals, which would be 1oz per 312.5 gals, correct? Hot tub is 330gal, added accordingly. 24 hours later, no FC, PH higher (7.4 up to 7.8), and phosphate level coming up the same dark blue in a pillow test. Using Taylor test kit for tests. What am I doing wrong, or should I wait longer for phosphate remover to work? Water has been crystal clear since fresh fill, I refilled it originally because it got cloudy. Purged with Ahhsome before refill. Need some advice or answers, getting frustrated! At present PH 7.7, TA 60, CH 150, CYA below 30.
×
×
  • Create New...