Jump to content

Catalina Spa Topside Panel & Cable Problem

Recommended Posts

My apologies for what is going to be a long explanation.

A while ago, my heater relay became intermittent and regularly failed to close but sometimes failed to open. I ordered new relays from China and with careful management was still able to use the tub. If the relay failed to close the tub just didn't heat up; if it failed to open the tub got hotter whether or not the pump was working or the heater light was on. One day I missed the relay being stuck closed, the water boiled in the heater and took out the element. 

Today my relay arrived and I replaced the defective one on the board and put the tub back together.

When first switched on my tub goes through a blower cycle and then sits there heating the water. Often I cancel the blower cycle if I'm stood next to it. When I tried to do that today the topside panel didn't seem to be working. There was also a relay continuously operating on the board - which turned out to be the one for the light. The temperature buttons were inoperative but the temperature is displayed. I could get pump 1 & 2 to respond.

After a while I decided that there must be an issue with the topside panel or its connection, possibly condensation etc, so I removed it and disassembled it but with no obvious defects found.
That made no difference. 

I disconnected the topside panel from the board and switched on the tub; it went through its blower cycle and then happily sat there heating.
I reconnected the topside panel whilst the tub was on and immediately the blower came on and off repeatedly in a similar fashion to how the light had. 
If I disconnected the topside panel just as the blower started it would remain running. If I disconnected it just as it was slowing it would stop.

This led me to believe that the topside panel was definitely the problem and it had somehow developed an issue whilst the tub was broken and waiting for its relay.

This is where it gets really weird...

I disconnected the cable from the topside panel to check whether moisture / corrosion during the downtime had caused a short. I checked each conductor on the cable to ensure that there was continuity from the RJ45 plug at the PCB end to the plug at the topside panel end. All conductors had continuity and non were shorted.
Whilst stood there with the cable in my hand I wondered if the action of plugging it into the board might be either making or breaking a circuit on the PCB and causing the problem.
So, I plugged just the cable into the board whilst the tub was running and the blower started its on off on off routine.
Assuming that the insertion of the cable into the socket on the PCB must have been altering a circuit somehow I tried the same thing with a normal RJ45 Cat5 cable but nothing happened.

There were no topside panel issues before the heater relay failed.
All I did was take the PCB out and replace the defective relay.

All connections were marked on removal and have gone back as they were.

My brain can't get past the bit where the tub RJ45 cable causes a problem and a Cat5 RJ45 cable doesn't.

Can anyone shed any light on this as I'm absolutely stumped now?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...