Jump to content

older vita spa upgrade???


 Share

Recommended Posts

I've got an older(2004) vita spa L700C i purchased used 2 years ago. Has worked pretty well. I started getting a flo error recently. I've know one of the pump motors was losing low speed. So i need a 4hp 2 speed motor for sure. Now twice the breaker been tripped out. I narrowed it down to the heater. This has an old vertical heater. My question is... is it worth it or even possible to upgrade spa pack on this old of a tub. If I bought a new tub I would want exact configuration i have. any help would be appreciated. Thanks.

vertical-heater-1-12-20.jpg

2012-01-16_003330_img_6371.jpg

Link to comment
Share on other sites

You could retrofit a new Balboa pack and topside into the tub and probably a new heater as well. The question is what's the cost benefit vs work vs expected life span. You are probably looking around  $1000 to do everything, not counting your time. What doesn't this tub have/do that a new one will have/do?

A new tub with warranty is $10K+ but will be worry free for 3-5 years during the warranty period. It will, as you said, be exactly the configuration you want.

The plus of repair is with the exception of the shell, plumbing and one motor, everything else will be new. The one motor and the plumbing is what's unknown and the risk. You also don't have to figure out how to get rid of it which is something you will have to do if you buy a new tub.

I might be inclined to go for the updates and repairs on the current tub but I'm handy and have all the tools to do it.

We can't make this decision for you, that's on you. I pointed out some pro's and con's of each option and I'm sure others will as well.

Good luck either way. 

Link to comment
Share on other sites

50 minutes ago, CanadianSpaTech said:

@cranbiz 3/4" tubing off the heater tube... retro fitting a Balboa system won't work. If you are certain it's the heater I am fixing what I have. See below

http://www.spapartsnet.com/Universal-Low-Flow-Heater-4-5-KW-p/unihq27v3106tk.htm

Its original to 2004, paid its dues. It must be shorted it. I've got it unhooked and everything works. Hook it up and it wont hold the breaker even for a second.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...