Jump to content

Mspa Soho - Not turning on


Recommended Posts

Strangest thing happened with my Mspa Soho…. Had it all plugged in and up and running but decided to change to another power source. Unplugged and moved to a new one, did the usual thing with the test / reset thing (all fine) and now the blummin thinv isn’t turning on! Nothing at all on the control panel…. So it went from working fine to not working at all within 5 mins!! 
left it for a day and tried again, still nothing (and I’ve tried multiple outlets) 

Any thoughts or advice? 

Link to comment
Share on other sites

Could have shorted something internally when unplugging the unit from the original outlet.  It *could* be something simple like a blown fuse internally, but I doubt even customer service would know where/how to replace it on that unit 😄

Inflatable spas are built to be cheap budget-friendly items.  They are not built to be serviced or repaired for an extended lifespan.  You're lucky to get several "seasons" before the the spa is worn out and needs replacement.

If I were in your shoes, I'd reach out to Mspa and see if they can offer any advice, but I doubt you'll get very far because like I said inflatable spas are not built to be serviced/repaired and they lack adequate documentation to help owners.

Sadly, If history on this forum and other sites has taught me anything - it's that this post will go unresolved - even if you figure it out, people rarely take the time to update the post with a resolution. And then in a few years someone else will join the conversation to say "I'm having the same problem with my inflatable spa, did you figure it out?" - which of course you'll be long gone and never reply.   But that won't stop dozens of other people from also replying over time saying "I'm also having this problem, anyone else figure it out".    🤦‍♂️


 

  • Like 1
Link to comment
Share on other sites

After this occurred, did you test the receptacle for power with an AC voltmeter or even a lamp?  I would think that a tub would need to be on a dedicated circuit, and likely a ground fault circuit, so check to make sure a breaker or GFCI hasn't tripped.

In most homes, stuff like refrigerator and washing machine get their own 20-amp circuits, where stuff like lights, TV, stereo uses shared circuits.  In my home, after I added an over-the-range microwave in place of a simple vent fan, use of the countertop microwave at the same time tripped a breaker, so I had to tap into another circuit for that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...