Jump to content

Balboa VS501Z with VL200 mini panel not working


Recommended Posts

I had this spa  with Balboa VS501z replacement pack with a VL200 topside running fine and then had a pipe union crack and almost all the water drained out.  When I fixed the pipe union and refilled strange things are happening.  First, it doesn't go through the normal power up sequence showing the SSID, etc on the display panel.  It displays immediately displays "Pr".  The light button on the spa blinks on and off constantly and is accompanied by a relay (I believe it is relay K8) going on and off almost in perfect timing with the flashing light button.  The light in the tub flashes as well.   When I tried to change mode to Standard (St) it immediately displays "--" and stays that way.  If I put it in Sleep (Sl) mode, it will heat and the low speed jets with go on but the light and relay continue flashing and clicking. During all this, pressing the Jets button has no effect.  The jets do not go on at all.  The blower turns on and off just fine.

I've tried resetting the J43 jumper.  I thought it might be the topside, so I unplugged it and still have the clicking relay (no flashing light) but no pumps or jets or heat go on.  Can some please advise!!

Thank you,

Jim Siebert



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...