Jump to content

Sundance Spa Issue


Recommended Posts

I have a 2004 Sundance Spa 6 person.  It seems like we are always battling a low flo error.  It almost seems to just randomly come and go.  I have replaced the flo switch but it didn't seem to resolve the issue.  I remove the filter and that doesn't seem to do any good either.  Is this a known problem for the spas or is the problem maybe the pump?


Thanks!


Keyser

Link to comment
Share on other sites

When you get the low flow error, is any water coming out of the heat return?

Is the water level at least halfway up the skimmer?

Does the weir gate float with the water level, or does it get stuck up?

When you get the low flow error, can you look at the flow switch and see if the two pieces in the middle are touching?

 

George

Link to comment
Share on other sites

If it uses a small Lanig circ pump it could be starting to go on you. They will sometimes start and stop then throw an error code. The circ pump is often tied to the waterfall so if it is turned on when only the circ is running keep an eye on it for the flow to start and stop. It can often be intermittent and hard to diagnose.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...