Jump to content

Softub running , no heat


Recommended Posts

Have the same problem,  with my motor V2 PCU SPA MOTOR.  it only worked for one season.  Motor works but no heat and Canadian Pool and Spa offered a replacement for $800.plus plus, very unhelpful.   They do not sell parts, beware of this. Needs a new heat stick but not sure where to get one.  If you have any luck let me now, I will also keep searching and let you know. 

  • Thanks 1
Link to comment
Share on other sites

1 hour ago, CarolG said:

Have the same problem,  with my motor V2 PCU SPA MOTOR.  it only worked for one season.  Motor works but no heat and Canadian Pool and Spa offered a replacement for $800.plus plus, very unhelpful.   They do not sell parts, beware of this. Needs a new heat stick but not sure where to get one.  If you have any luck let me now, I will also keep searching and let you know. 

Heat stick?

Link to comment
Share on other sites

  • 2 weeks later...

Ok I talked with my local Softub service shop and the owner was super helpful and very informative it's probably not the temp or high limit sensor but rather the main control board. She sent me one she had that is a good used one to try for $150 and comes with a 30 day warranty. If this doesn't fix the problem then she'll credit the price I paid towards a new main control board. Today I will swap out the boards and will follow up....

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...