Jump to content

2020 Grandee - Blinking Green Status Light


Recommended Posts

I just moved my 2020 Grandee to a new house and upon refilling and reconnecting, the green status light is blinking and the blue power light is solid.  The troubleshooting section of the owner's manual states that the probable cause is a temperature sensor problem.   It suggests disconnecting power for 30 seconds to reset the system.  I did this and the green light is still blinking.  The heater is working and the spa has reached the desired set point.  Where is the temperature sensor located?  What else can I do to troubleshoot the issue?  Thanks!

Link to comment
Share on other sites

Posted (edited)

Thanks for the reply.  Yes, I have a FreshWater Salt System.  I just replaced the cartridge yesterday.  The system status shows Inactive - Low Status.  This is after adding about 9 cups of salt.  Current NaCl level shows around 1500 ppm.  Upon removing the front panel, the FreshWater Salt System error light is flashing red.

spa status.jpeg

salt_status.jpg

 

system_error.jpg

Edited by Scott B.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...