Jump to content

Caldera Spa No heat


Recommended Posts

As the regulars here know I am a Watkin's spa idiot...just don't see many in my area so my knowledge is limited and there are several things going at once on from what I can tell. Have a Caldera spa "Martinique" (S/N:  MRA4P5088) with no heat. On the topside I have Power and ready lights flashing in unison. Circ pump is running and moving water. On the circuit board I have a Red LED at D21, Green at power ON and also green LIM OK. All incoming power checks are good. 

At the top right of the small board there is a darkened area at See Photo 2:

P1040964.thumb.JPG.f97a929f8a07b9474ff3c186640bfd18.JPG

P1040965.thumb.JPG.433473f7fd2493573b38183ddf0e58c1.JPG

 

The heater tube black box has a drip see photo:

P1040972.thumb.JPG.52b635bd6d4a65f1d4b7c58808963ef8.JPG

 

Heater has continuity and measured 14.3 ohms. 

I did not test or jumper the pressure switch...it was 1000 degrees in full sun and was not thinking clearly...lol

So where am I going and what am I doing?.. lol

Go back and test/jumper pressure switch

Replace heater relay board

replace heater

all of the above

or...

Recommendations?

@RDspaguy @castletonia @cranbiz

 

Link to post
Share on other sites

Not sure why the board is discolored there, The diodes and resistors are a decent size for SMD's so there could be some decent current thru there. The IC is an Opto Isolater. They don't normally fail and are really cheap (like under $1)

My guess is those components are OK, a stuck relay would cause those components to get hot, causing the discoloration to the board. Except for the opto isolator, the rest are easy to check with a multimeter.

  • Like 1
Link to post
Share on other sites

Yeah I'll have to go back over again. Luckily only 10 mins away. When I went yesterday just had to much on the brain and it was XTRA hot and humid after a short rain and just didn't want to be there...lol.  It happens.

Yesterday me is such a D ck.. now Today me seems to think that it would be better if Tomorrow me deals with it...🤣

  • Like 1
  • Haha 1
Link to post
Share on other sites
5 hours ago, castletonia said:

Do the jets work?  

Everything works just no heat/power out of H1 and H2. I see the D21 question asked every now and then but never an answer.

Anybody know what's inside the black box on the heater?

Is there anything serviceable inside that might be causing the drip.

Link to post
Share on other sites

Went back by and did some more testing with little success. I tried jumping the pressure switch at the circuit board but still no heat/change. Removed the black cover on the heater where there is noticeable water but could not see any drip or leaks but would have to say it is coming from the pressure switch. It looks like there is a small circuit board sandwiched inside the pressure switch and not sure if it plays a part in why jumping it at the board had not result. Thoughts?

@RDspaguy @castletonia @cranbiz

P1040974.thumb.JPG.5b261a35533d78f4df780b817163452e.JPG

 

P1040973.thumb.JPG.93e6c7555ff1738284ecc804bd224890.JPG

Link to post
Share on other sites

I did tip the relay board forward and it looked good on the back around the relays. Only area was top right that was darkened. Have a new heater unit ordered. Heater needed to be replaced one way or the other due to the leak/drip and overall condition of the pressure switch that has a lot of green corrosion. Just the pressure switch not available and have to replace the complete heater unit. Relay board will likely be next but customer is not in a big hurry so one step at a time I guess. 

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...