Jump to content

Taylor ph test fades away


Recommended Posts

I’ve been running softened water in my hot tub without much trouble using bromine. Today I did a fresh fill but went with about 75% straight well water and the rest softened water. Thought it might help with some cloudiness I see with a flashlight beam into the water at night. Anyway in the past my good ALK level seems to be around 40. I brought the water back to that level. Today I was using a digital ph tester to check and aireate the ph and Taylor test for the ALK. Now my ALK shows 40 using the Taylor test. Should be ok. Thought I’d verify my PH using the Taylor test. The Taylor test shows it 7.5. But within seconds right before my eyes it fades out to 7.0. I don’t get what’s going on. Calcium is at 190. Is well water jacking up my test? It’s been reliable until now. Hope this makes sense. When the well water was tested a while back, I was told the metals weren’t abnormally high but can’t remember the exact numbers. Any ideas would help. Thanks!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...