Jump to content

Replacing Mood Lights on Clearwater Beechcraft 6 person Hot Tub


Recommended Posts

We bought this Clearwater Hot Tub 10 years ago but the dealer has long since gone out of business. It has been very good - just had to replace one pump so far. We have 2 bulb problems I can't work out - so any suggestions welcome. 

Problem  -  All of the small round LED twinkling mood lights on one of the waterfalls have suddenly failed and also behind two of the Pillow positions. Is this likely to be a general fuse problem or a transformer problem, or just a set of bulbs? I have assumed they are all connected together and not zoned. The other waterfall lights are fine as are the other lights behind the pillows. I can see they are screwed with a nut from below, and they all come back to a local interim small white plastic box - would that be a transformer?  
 
I have had two Hot Tub engineers over - but they are not interested in electrics sadly so I am just trying to see if I can figure it out. 
 
Thanks 
Link to post
Share on other sites

Clearwater has used several different LED light systems over the  years. Yours likely has an LED system made by Rising Dragon. There is a main power line that runs completely around the spa from the power source. The system uses clips that can be crimped onto the main line at any point.  The clip goes around the main power line and the Light strand has 2 sharp metal points the will pierce the 2 wires to make a power connection. Make sure it get crimped all the way closed.  

https://www.hottuboutpost.com/rising-dragon-led-harness-clip-pk000-00001/

Then the LED light strand plugs into that clip. The LED light strands (Mini-Pols) come in different amounts of LED light points. You can have 2, 4 or 6 strands off one connection.

https://www.hottuboutpost.com/clearwater-lights/

Are all the non functioning light points in the same area of the spa? You likely have one strand with 4 light points that has gone bad or has a loose connection at the main power line and needs a redo or a new clip but chances are it's a bad strand.

https://www.hottuboutpost.com/clearwater-mini0-rd0c6-mini-points-of-light-led-6-way-rising-dragon/

 

VERY IMPORTANT: The light lens that screws into the tub and holds the LED in place and illuminates has the lens on the inside of the spa and is held in place with a nut on the backside.. inside the spa cabinet. Make sure to order several of these and have them on hand when you do the job. It is very likely it will break off. You should be able to remove the LED light point from the lens/holder but they have a boot that goes over it  and become very brittle over time and I have broken many just trying to get the LED light to pull out. 

https://www.hottuboutpost.com/clearwater-light-lens-rd631-1135-led-pinnacle-rising-dragon/

http://www.risingdragonplastics.com/en/products.php?sid=117

Not sure how the waterfall lights are plumbed in or how they are held in place. 

 

Again they have used several different systems over the years so you will need to confirm this is the correct system. Post photos if unsure

  • Like 1
Link to post
Share on other sites

Thanks very much - that is very helpful. I will absorb everything you have suggested and let you know. They don;t seem to peirce into a ring main - rather they are appear to be plugged into little routing boxes - which then route away back to the power. ( Lots of them on each section about a foot away from the lights. Yes - all the non functioning lights are in the same area.  I have continued researching and think they may be on a thing called a Sloan Harness ?? - certainly looks similar to this when I looked on the internet. I'm in London - but they seem to be available over here.  But at least I have a lot more direction now. Very good tip on the nuts - I'm glad I didn't try and remove any before you told me! I will try and take it forward and can add a photo of the parts ( if it ever stops raining and snowing!)   Thanks again. 

Link to post
Share on other sites

Ok yes same idea just how they connect is different called a daisy chain system. You will have to find the connections at both ends of the strand to replace...unless it is at the end of the line. I will usually cut the boot with a knife if I have to use even a little tension to get the LED out of the lens/holder. You shouldn't have to remove any of the nuts...unless you break one. 

https://spacare.com/SloanLEDLightQuadStrand78701564-4-DLO-XL.aspx

I have a Clearwater Spas 2012/13 parts cat. on PDF if you want it just PM me your email and I will send it to you.

  • Like 1
Link to post
Share on other sites

Dont know if your connectors are similar but I did a huge repair on my hot.springs this summer. Most of the 30+ lites didn't work at all. I replaced every bulb amd a ton of wire, the clips that attached to the single feed around tub were either perfect or rotted out. I ended up cutting the factory plug off amd there was simply red amd black wire on each light. I soldered groups together amd shrink wrapped them.  The waterfall was led but fiberoptic feed to that light output. Think outside the box if need be and experiment if need be

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...