Jump to content

Recommended Posts

We have been dealing with brown water in out Subdivision for several months now.  Have to call city and have them flush lines to get clear water for hot tub.  This the second time now I have filled with brown water and now my filter is getting clogged.  What the best way to get this out of filter?

b1bb2e8a414be89a652c0d58f7f33272.jpg

Link to post
Share on other sites

Suggest first you purge the spa with Ahh-Some line cleaner and soak your filters is the solution as well.  Then drain and clean the spa and rinse filters well. Might want to call a water truck for future fills until water is sorted out. 

Call 1-800 number or email Ahh-Some and get their recommendation for removing rust... https://ahhsome.com/wp-content/uploads/2020/08/Ahhsome-Hot-Tub-Instructions-042420.pdf Contact information at bottom of page.

Link to post
Share on other sites

Ran cleaner through last night.  Some funky stuff came out.  Have hose filter coming today.  Going to give that a shot.  Have new filter coming Monday.  That new pump got me fixed up.  Ready to use this thing again.  Maybe get another 20 years out of it. 

Link to post
Share on other sites

Of course that did not work.  Had them come out and flush the lines through hydrant.  Still brown.  Ordered some stuff to clear water and will run through old filter.  I bought a new one to put in when I get clear water.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...