Jump to content

Hot Springs Vanguard heater not heating


Recommended Posts

Today I noticed my water temp is in the 80’s so immediately I looked at the Power and Ready lights on the front panel. None were blinking indicating a problem with the unit and/or heater. So I took the front panel off to check the IQ 2020 panel to see if the lights for the heater were on.  And they are.  The recirculating pump is running fine so I know the flow is good on the pressure switch.   I’ve shut the breakers off and on a couple times and you can hear the “click” noise the heater makes when it turns on, it’s just not heating   

Sunday I did a water change using the Ahhsome hot tub cleaner. Followed the directions and all was good. Drained the tub and filled back up, got the water levels all within spec and the heater was working at the time.  But today, not so much.  Could the water changing messed up the heater in some way or just coincidence that the heater went out right after?
 

 

Link to post
Share on other sites
5 hours ago, EPIC CAJUN said:

Could the water changing messed up the heater in some way

Sort of. When you fill, the heater will run for a much longer duration than any other time, and any issues are more likely to show themselves then. I suspect you need a relay board, but first double check that you have proper voltage into the spa on both circuits. 

If that's good, pull the small relay board and check the back for burned solder joints. 

Post a pic of your circuit boards.

  • Like 1
Link to post
Share on other sites

Man I feel like I dodged a bullet on this one.....

After typing my original post, I went back out by the tub looking for any signs something was bad on the heater and relay board. One of my kids walked up and told me she turned the temp down to 83 the other day for no reason....  So I check and sure enough, temp set at 83.....This makes sense now because the heater lights were on indicating it was working, its just the temp was turned wayyyyy down.

The one thing I never thought to check was to press the temp button to see where it was set. 😣  Thanks for the help tho RD!

She is now grounded from touching anything electrical in the back yard until shes 21 🤣

  • Haha 3
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...