Jump to content

Costco Divine Sinclair Panel Went Dark


zich6
 Share

Recommended Posts

Last night the 2.5 year old tub (so out of warranty) shut off and the panel went dark.  I cycled the main breaker and the subpanel 50amp breaker with no impact.  The manual also says to check the fuse which I believe is a 7amp for the pumps.

Before I take the panel off and start checking things, any advice?

Thanks.

 

 

Link to comment
Share on other sites

Yes...Take panel off and post photos of the circuit board as well as the diagram on the inside of the control box cover. Pump fuses are usually 25 or 30 amp. Usually the glass F4 fuse is what I would check first if everything is dark but that would depend on the pack brand as well. I think Clearwater spas (Devine) uses balboa packs. Do you have and have knowledge of a multi meter to test fuses and power?

  • Like 1
Link to comment
Share on other sites

It is a Balboa pack.  After letting it sit all night I cycled all the breakers again including the subpanel GFCI test and it booted up.  We get some goofy power spikes here and that could possibly have been the culprit.

Thanks for the excellent analysis and quick response.  Nearest tech is a $300 trip charge away, so I'll be relying on this forum if I have problems in the future.  Last week I replaced a leaking slice valve coupler myself.

Thanks again.

 

ht old assembly.jpg

HT Leak1.jpg

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...