Jump to content

Tropic Seas Spa Maui Control Panel/Electric Issues


Recommended Posts

We have a Tropic Seas Spa Maui XL (2 pumps) that we can't get power to. Have checked power to outside box, GFCI and both look good. Replaced the control panel. Still nothing. I don't think it's a fuse because when the panel/power went out, the control panel faded in and out a bit before the pumps shut off. It came back on a couple of times, then went out and never came back. The panel had gone out before in similar fashion, so we replaced the control panel. But nothing powers on. 

I can't find a diagram of the internal electric panel/box. Does someone have a link/copy? I doubt it's a fuse or high limit switch since it faded in and out, but I guess I need to check. 

Anybody have any other thoughts on what it could be that would cause a short/fade in/out like that?

Thanks!

IMG_3829.jpg

Link to post
Share on other sites

There should be a schematic inside the box cover.

How long has the new control panel been in? I assume you are talking about the screen and buttons part (topside controller)?

I would suspect an electrical issue such as a bad contact on one phase of 240v circuit breaker, or a faulty board. A bad board can damage the controller, so I would get a new pack with topside.

Post a close up pic of the board and any stickers on the board or box.

Verify steady incoming voltage on both phases at the circuit board.

Link to post
Share on other sites

Thanks so much for the info! I'm always grateful for the help of folks. :)

We did just install the new topside controller. It's the 6 button one. Photos below. I'll check the main board inside tomorrow to get photos and check the voltages. It's getting dark, but looks like we may indeed have lost a fuse as well. Is there somewhere you prefer to get fuses/parts online? Any reason to buy only branded fuses for the Artesian/South Seas electric?

Here's the new controller (sans sticker while the silcone dries):

 

image.thumb.png.362269f06d226a60098b7710b2e1fbc2.png

 

 

Here's the old one with sticker. 

 

image.thumb.png.8357e7eb666cf2752242f7efc2096ea1.png

Link to post
Share on other sites
  • 2 weeks later...

Ok, so we had to do a bit of testing. Here's what we know:

- The wires coming into the hot tub are hot and the breaker box seems functional. 

- Our spa came with the stereo. We had no idea what a bad idea this was until after we got it. We've removed the speakers and plugged the ports on the tub up. We have discovered there's a fuse on the A/V module was blown. We replaced it and it blew again.

- Also, the ozonator box tested hot on the voltmeter, so we disconnected power and were worried it might have water in it. Instead, we found a capacitor had blown completely off the ozonator board. 

- We've tried disconnecting each separate module that connects to the main electrical board (stereo, ozonator, etc.) on the main board and turning the power on. Several things came of that:

a. the stereo fuse blew again (after we replaced it). it smells scorched.

b. the main breaker blew at the same time - so obviously something is going on with A/V

So a few questions for you:

1. Does the main control panel do some sort of test on power up that requires all the modules be plugged in/functional on startup? (this doesn't make sense b/c it was working fine for months since we removed the speakers)

2. If not, can we permanently disconnect all the A/V from the control board and be ok?

3. We obviously need a new ozonator board. Is there anything related to the A/V that might have also caused the ozonator capacitor to blow? Or maybe other random wear/tear? Anything to specifically troubleshoot on ozonator electric problems?

4. We still could have (as you suggested above) a bad topside control panel. It has never worked since we got the replacement in. So what do you recommend we try first? Replacing the ozonator control panel and leaving the A/V unplugged from the main electric board? Then if that doesn't work, replace the topside control panel? Then if that doesn't work replace the main electric board?

Thoughts?

Thank you so much!

 

Link to post
Share on other sites

P.S. The hot tub is outside, and we are noticing that it looks like there's some water markings inside the panels. Not sure what may have gotten wet other than the A/V box. It's below ground in a specially drained concrete pit with a deck above it. So we may have some water damage issues that we're dealing with too. 

Link to post
Share on other sites

Ok, quick update, he's done some jerry-rigging in the A/V box, and we're to the point where we can turn everything on without the breaker or fuse on the A/V tripping. I've ordered an ozonator since we know we need to replace that. I'll wait to see what you say before ordering anything else. 

Link to post
Share on other sites

Wow, been a busy day, huh? 

"Jerry-rigging in the av box" does not inspire confidence. 😉 Please turn off power and unplug the av from the board. 

What "everything" is working, exactly?

I don't believe in coincidence when it comes to a spa. You have multiple issues going on and I suspect they are related. Water on a circuit board can take out alot of other components. Turn off power before anything else gets damaged and post a pic of the circuit board. 

Link to post
Share on other sites
On 8/7/2020 at 4:29 PM, HotTubGal023 said:

Replaced the control panel

To be clear did you replace just the topside control or the spa pack with the circuit board inside or both? 

Please post photos of the circuit board and diagram on the inside cover of the spa pack

Make sure the ozone you ordered is the same voltage as what you currently have otherwise you will have to make wiring changes on the circuit board so you don't burn it out before you even get started.

Link to post
Share on other sites

Thanks much from both of you. I've tried to present all the information again in order of occurrence, added corresponding photos for you, and rephrased my questions at the end of this post.

Original Issue

The original issue in this post (we thought) was the topside control panel flickered in and out for several minutes, then finally permanently failed and had no power/no errors/no lights/nada. The topside control panel did get wet from an accidental overfill (and the topside control panel went out within a day or two of the overfill). 

Some things to note: The A/V water damage I mentioned in a previous comment was from 2015, was contained only to the A/V box (not the iphone port but the A/V box/board where the speakers connect to see photo7-AVpanel). We let it dry out, and things worked fine for a few years. A few years later, the topside control panel stopped working. We replaced it. The spa has been working fine for a few more years until this most recent issue of the topside control panel going out. 

Also, earlier this year (May), my partner removed the speakers and plugged up the speaker holes in the tub (the speakers had rotted through years ago and the speaker wires are still there, hanging in the spa walls with no speakers attached - now the speaker cables are still plugged into the A/V board via that one plug from the speakers). I realize this is likely a problem, and I have a question about it below. We had no problems with consistent use for months until early August when the topside control panel went out again.

What We've Done So Far

Here is the order of what we have done so far for this most recent incident:

1. Replaced the topside control panel on August 7. That installation has never gotten power/lights/anything. We did NOT replace the internal circuit board that all the various components plug into inside the wall (see images 1-newtopsidecontrol  & 2-3-4-5 of spa pack/main circuit board). We have noticed that the new topside control panel does not ping with our voltage pen when the power is on to the tub. Not sure if the voltage is just too low to detect or the newest topside control panel is faulty. The circuit board part number on the outside is Balboa Water Group MVS 504 SZ Part# 55173-01.

2. After a more detailed look inside when the new topside control panel didn't work, we found 2 things of note:

         i)a capacitor in the ozonator had blown off the ozonator circuit board (image 6-ozonator)

         ii)a fuse inside the A/V box had blown - not main circuit board but where the speakers plug into the A/V box (image 7-AVpanel)

3) He replaced the blown fuse on the A/V circuit board in the A/V box. Turned the power on again to check to see if the topside control panel would work. Nope. We had the new fuse blow twice (once tripping the main power breaker) before he did step 4. The breaker had never tripped before step 3. 

4) He removed the 110/220 switch on the A/V circuit board AND replaced the blown fuse (again) in the A/V box. The breaker and fuse held. But still no power to topside control panel. 

In response to RDspaguy, "everything" working on the main circuit board means now all the A/V, Pumps, etc. - everything but the ozonator - are plugged into the main spa pack/circuit board and do not trip any fuses or the breaker when the power is on to the tub. The topside control panel still won't do anything when we turn power on. No lights, nada. Yes, the main power lines are reading as hot on our voltage pen, as is everything inside the spa that are connected to power EXCEPT the topside control panel. 

Questions on how to proceed:

1. We still could have (as RDspaguy suggested above) a bad new topside control panel. It has never worked since we put the replacement in back on August 7. We need to troubleshoot in some methodical way to figure out what the overall problem(s) is/are. What do you recommend we try first? Here's what I'm thinking:

      a) Replace the ozonator control panel and see if the topside control panel works after that. It's already ordered. I checked the specs to make sure I ordered the right one. 

      b) If the ozonator replacement doesn't work, then also replace the new topside control panel.

      c) If a & b don't work, then also replace the spa pack/main circuit board.

2. Since the speakers are gone already, can we permanently disconnect all the A/V from the control board and expect it to work properly? Or does it do some kind of test that requires the A/V to be plugged in before it will function?

Thank you both so much! We'll call a tech if we HAVE to, but I'm confident we can just troubleshoot parts until we get it to work. Famous last words. :)

1-NewTopsideControl.jpg

2-exteriorcircuitpanel.JPEG

3-interiorcircuitpanel.jpeg

6-ozonator.jpg

5-diagramcircuitpanel.JPEG

4-interiorcircuitpanel.jpeg

7-AVpanel.JPEG

Link to post
Share on other sites
2 hours ago, HotTubGal023 said:

  a) Replace the ozonator control panel and see if the topside control panel works after that.

Has nothing to do with the topside. Replace the new one when you get it and make sure it has the right voltage that is determined by the white wire going to either White AC for 110V or to RED AC for 240V it is currently wired for 240V

Disconnect the AV from the board it is apparently no longer needed if you have removed the speakers.

Have you tested for continuity the F7 fuse and also the F1 fuse?

Does the spa have a circulation pump? I see there is a component plugged into J47 and the diagram Table 1 says J47 not used. And the the Switchbank A (little red block along the bottom of the circuit has toggle #9 in the up position for 24 hour circulation so from all of this I will assume you have a circulation pump tied in. None of this is tied to your current issue just noticed it is all.

If those fuses test good then I can't think of any other fixes for the topside other than to remove the circuit board and take it to a local electronics repair shop and have them test the power for the low voltage side of the board. I have seen this recently with Gecko spa packs and is repairable in some cases. When the board is removed have a look on the back for darkened or burnt areas.

 

3 hours ago, HotTubGal023 said:

  b) If the ozonator replacement doesn't work, then also replace the new topside control panel.

      c) If a & b don't work, then also replace the spa pack/main circuit board.

B) Would have to think the topside is good if it is new and is the right one for the pack. Yes new can also be defective but that percentages are minuscule IMO.

C) Last resort

 

  • Like 1
Link to post
Share on other sites

It appears that everything but the av is wired for 240 volts. Check for 240 volts black to red and 120 volts black to white on incoming power. You need a mutimeter for this, a voltage pen will not do.

Is the new topside the same part number as the old one? Try plugging it in to the other port on the board. Check all fuses, especially f4. You need a mutimeter for this, a voltage pen will not do. 

 

Link to post
Share on other sites
3 hours ago, HotTubGal023 said:

Yes, it does have a circulation pump. Everything is 110V.

As Rd mentioned the ONLY thing wired 110V is the AV. 

I notice the Pump #1 only has 3 wires and should have 4 according to the specs that I looked at here: https://tropicseasspas.com/models/maui/  pump 1 should be 2 speed and that needs 4 wires. It could be 2 high speed only pumps but that (to me) is a bit unusual. Just saying. Can you post a photo of the white sticker on the #1 pump.

If you look top right of the circuit board you will see a cluster of male connections labeled White AC this area has only 1 white wire attached that goes back to the circuit board beside where the AV plug is (W4). White AC is for 120V components 

The cluster bottom left in the RED AC area with several white wires attached is for 240V components.

Please check the new ozone that you ordered and ensure that it is for 240V operation. 

2 hours ago, RDspaguy said:

Check all fuses, especially f4

and yes the F4 fuse.. my bad. Thought I included it in my earlier post.  It powers the circuit board and also the topside control. Nice catch RD

  • Like 1
Link to post
Share on other sites

Hey there, you both are awesome! Thank you so much! We've made major progress. Replaced the ozonator and F4 fuse. We unplugged the A/V from the main circuit board (since we aren't using any of it). Now the topside control panel powers on and is functional. Most everything seems to work now. Here's the next round of craziness:

1. When we power up, the topside control panel throws a series of error codes that I can't find online anywhere:

752, 152, 93, 42, 24, then Pr 

Nothing comes up that I can find in the owner's manual or online for those codes. "Pr" comes up frequently when we power up the hot tub when there aren't any problems. I've always thought it meant "prime" as in priming the pumps. George thinks it means power. Do either of you know what these codes may be? Is one possibly because we have now unplugged the A/V?

2. None of the internal LED tub lights work now. We know it's very unlikely they all have gone out at once. We replaced the F1 fuse - but we aren't even sure if that's the right one to replace. Any suggestions to troubleshoot lights? Could it be a bad button on the new topside control panel? Or is there a specific fuse for lights as well (just not F1)?

When replacing the ozonator, George realized there was water in the tube from the ozonator to the tub. So we suspect that when the tub was overfilled (the primary catalyst for all the problems), it seems to also be in conjunction with the one-way valve in that tube also failing...thereby pushing water into and killing the ozonator. it doesn't look like there was ever any water in the main circuit board box, but there did appear to be a small amount of condensed moisture in the F4 fuse (even though it did not look obviously blown). 

At least the important stuff is working - the heat, topside control, pumps, ozonator. We both say thank you for that! 

Link to post
Share on other sites

The numbers on start up denote spa pack programming and are normal. "PR" is prime mode. Once you get to PR you can wait the several minutes or just press temp up or down and the spa should start up and run. You should see low speed water movement at that point.  

Sorry should have had you test the check valve on the ozone. Common failure of a $0.20 part that causes all kinds of havoc and $$.

F5 fuse should/could fix the light issue.

Enjoy

 

Link to post
Share on other sites

Welp. We’ve replaced every fuse. Reset the light connectors. Still no lights. 

 

Everything else works fine. I guess we could have a bad light button on the topside control panel, but no clue otherwise. We don’t want to have to replace the main circuit board just for lights. 

 

Since all the tub stuff is working, we are going to close it all back up for the weekend of storms. I can live without lights if needed. If you have any other ideas, we’re up to keep troubleshooting next week. 

Again, thanks so much to both of you!! 

Link to post
Share on other sites

Disconnect the red male female connectors on the twisty black and white wires for the lights and see if you have 12V coming off the pack. Where do the black and white wires end up? Do they go directly to a single light or to a light controller and then to the lights. Likely there is a light controller that will need to be replaced. Post pic of where the black and white wires end up.

Link to post
Share on other sites
  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...