Jump to content

Recommended Posts

Hi we bought a new Bestway Palm Springs inflatable spa a week ago and everything was perfect the first day but since then when we activate the bubbles we get E02 error code for the flow. We have tried all troubleshooting online.

Filters are not too dirty and have been cleaned daily, got the same error with replacement new filter, no kinks in tubes or debris in the lines, did a thermal reset but no change.

Today we ran the spa with no filter and just the housing and after 2 mins of running bubbles the error code started, we then removed the housing totally and the code did not come on so this suggests to me there’s an issue with the filter housing. The membranes look ok and are flat against the sides as they should be.

When the filter and heater are running without bubbles the tubes between spa and egg are full of water but when the bubbles start there are large volumes of air entering the filter. Strangely if we remove the housing then this does not happen and the tubes are full of water.

If anyone has suggestions for what we could try it would be appreciated.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...