Jump to content

Spa water temperature less than setting


Recommended Posts

I have a 2000 Sweetwater Palermo spa.  The water temperature is 3 degrees lower than the digital readout on the display on my control panel.  (the temperature from a thermometer of the water reads 97 degrees but the display reads 100).  I have a new heater, new filter and recently changed the water.  I've had this spa since 2000 and am very familiar with how it heats and this is really not normal for the spa.  Any clues what the issue might be?  Sensor, topside control panel, etc.?  Thanks.

Link to post
Share on other sites

I have seen this problem. If I recall the temp sensor made for some Sweetwater's were specific to Sweetwater even though they looked identical to  LX10 and LX15 sensors made by Spa Builders inc. If there has been any replacement of the sensors this might be why. Also check how the sensor is reading the water temp. In some temp wells the sensor can slide back away from the water it is there to moniter. this gap might explain the 3  degree difference

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...