Jump to content

Troubleshooting at my wits end


dwise
 Share

Recommended Posts

 

I've got a 5 person spa that is about 5 years old. I can't remember the exact brand but it was nothing fancy. Brand doesn't matter much since all the guts are replaced at this point. But I'm having an issue with the GFCI tripping.

Here's what I have and what I have done. 

I replaced the control board with the SpaGuts VS500Z Spa Controller with Heater attached, 56246-01 (Balboa parts branded under Spa Guts)

The dual speed motor started malfunctioning on low speed, and I removed it and took it to motor repair shop and they got it running again, but it only worked a month or so and burned out again. So I replaced the motor with a  Waterway Executive 56-Frame 4HP Dual-Speed Spa Pump - 3721621-1D

The spa worked for a few weeks and started throwing the breaker again. so I replaced the heating element  with an upgraded titanium heater and replaced my older GFCI Breaker with a New Circuit Breaker Eaton Cutler Hammer GFTCB250 GFCB250 50 Amp Self Test GFCI 

Again, spa worked for a few weeks and started the same tripping behavior. I sent the Spaguts control board in as it was under warranty and they sent it back saying it worked fine. Here's the actual technician notes. 

 “Upon evaluation, we found A LOT of Water Stains inside the controller box. There is ALSO RUST on the Transformer. We see that customer INSTALLED a Titanium Heater Element.  We WATER TESTED the Spa Controller with our Topside Panel and Pump, and it works and heats fine. NOTHING is wrong with the return Spa Controller. Looks like a FIELD INSTALLATION ERROR when customer replaced the heater element, and allowed water to infiltrate inside the spa controller and got onto the transformer. When the system was wet, it may have caused the controller to not work properly. Now that it is DRIED, the system is working properly again. CUSTOMER to protect the Spa Controller from Water Infiltration. Water Damages are NOT covered under warranty. “

(I did not allow any water to hit the board when I replaced the heating element, I’ve tinkered with spas for almost 20 years and replaced 4-5 boards at this point)  I almost feel like this is a cop out to avoid a warranty repair-even though they claim it worked)

I put the board back in and checked every connection and the spa is still tripping. 

There is an ozonator and the light that came with the spa also connected to the board.

I feel like every part has been replaced but I am still having this issue.

 

Any thoughts or ideas at this point? 

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...