Jump to content

Goplus inflatable spa help


Recommended Posts

Hello, 
 
I have a goplus inflatable spa,  model PH050017. I purchased it new on eBay several months ago.  It has been working great up until now.  During the recent hurricane , I drained it and stored it in the garage. In order to move it, I stood it on its side and rolled it from the side yard into our garage. After I set it back up today, everything works except the heater. When I press the temperature button it makes a beeping sound and the display is stuck flashing 68 degrees and won't change when I press the arrow keys. I drained the spa again and flipped it over but there is  no reset button or breaker underneath. I called the number in the manual for the warranty center  but was told that they no longer service goplus products and I was give  a website to visit http://www.firstspausa.com/ which only has an email address to contact for support. Any ideas? 
 
Link to post
Share on other sites
  • 5 months later...
  • 4 weeks later...
On 3/1/2020 at 3:32 PM, kelseyeparker said:

Did you get a resolution to this? I am having the same issue. Thanks!

No, not really. I've found that if I push the heater button, then the temp button and really quickly press the up arrow I can set the temp. But as soon as I stop pressing the up arrow, the temp rapidly drops back to 68. So, the trick is to rapidly press the up arrow until I get the temp I want, then quickly press the temp button before the temp drops back down. I've got it set at 94 and it stays there. The heater itself works intermittently,  sometimes it works without the red light on the heater button being lit up too.  

Link to post
Share on other sites

Yep. If I wanted to spend hours of my time trying to find out what is going on with your inflatable spa, I can find a hundred videos that do not show me what I need to see to help you. Or, I can have a reasonable expectation that you came here looking for help because you want to fix it and are willing to put in the effort to do so. I can only do so much from here. If there is no access to the pump, and whatever else they have in there, there is no fixing it. 

Link to post
Share on other sites
  • 2 weeks later...
12 hours ago, RDspaguy said:

You got into it? Great! Would you post a few pictures of the equipment? 

That is a cute little heater. Never seen one like it. Perhaps there is a manufacturers label on the heater or whatever it was mounted in?

the label says kawai 1805 120v 900w tried looking at there website but they just sell large amounts to the manufacturer of the hot tubs so cant just buy 1 or 2 looking for a site that might sell these.  normally i would just go to local spa dealers but most of them are closed due to covid -19 any other suggestions of where to get one would be great  Thanks for your time have a great day stay safe 

Link to post
Share on other sites
  • 1 month later...
On 3/26/2020 at 8:35 PM, NickB said:

No, not really. I've found that if I push the heater button, then the temp button and really quickly press the up arrow I can set the temp. But as soon as I stop pressing the up arrow, the temp rapidly drops back to 68. So, the trick is to rapidly press the up arrow until I get the temp I want, then quickly press the temp button before the temp drops back down. I've got it set at 94 and it stays there. The heater itself works intermittently,  sometimes it works without the red light on the heater button being lit up too.  

Did any of you have any luck?  Mine was working great until the FC started flashing. I then disconnected the power to change filter. When I plugged it back in, nothing lights up at all. Any ideas?

Link to post
Share on other sites

Return it where you bought it. Then go on craigslist for sale section or facebook marketplace and search for spa or hot tub. There do not seem to be any answers available for inflatable spas. From what I can tell they are all junk. Write a review or twenty to maybe keep someone else from making the mistake of buying one.

  • Like 2
Link to post
Share on other sites
  • 3 weeks later...

I have the same inflatable Hot Tub, My heater stopped working this year. I took out the heater, it is pictured just like the one above. I see my heater element actually split open. I called the GoPlus company, they told me they no longer sell replacement parts. I have searched all over the internet and have not been able to find any replacement parts. Was told by Go Pus that I just need to buy another hot tub.  Was wondering if anyone else have been able to fix their hot tub. Thanks

Link to post
Share on other sites
  • 2 weeks later...
On 6/12/2020 at 4:00 PM, Suzyqsjewelry@gmail.com said:

I have the same inflatable Hot Tub, My heater stopped working this year. I took out the heater, it is pictured just like the one above. I see my heater element actually split open. I called the GoPlus company, they told me they no longer sell replacement parts. I have searched all over the internet and have not been able to find any replacement parts. Was told by Go Pus that I just need to buy another hot tub.  Was wondering if anyone else have been able to fix their hot tub. Thanks

How do you get at the heater.

Link to post
Share on other sites

Has anyone tried a submersible heater? I found one on Amazon and I am wondering if it would work for this. I am getting the impression that this is a crappy hot tub. I only got 2 1/2 months total with mine. The heater died two days after the one year warranty.

Link to post
Share on other sites

Submersible heater wouldn't be the way to go as they are much harder to regulate for a hot tub based application and would also likely burn the tub material itself (I say this as someone who owns an inflatable tub and a saltwater and freshwater aquarium with submersible heaters).  They are also very prone to failure.  As for the tub itself these are actually manufactured by a company called Costway (they also make tubs for the british label Cleverspa) and unfortunately the Costway pumps are prone to pre-mature failure.  You can try seeing if you can find the replacement heaters from the site but right now there is a world wide backorder on pretty much anything inflatable by any manufacturer(popularity has skyrocketed due to world events and people not being able to get out as much as they would like).    If all else fails you could look into Lay-Z-Spa (All of them are made by a company called Bestway), Intex or MSpa.  The best deal stateside right now is the Coleman (Bestway) Lay Z Spa Havana at Walmart.  It's not a big tub (2 adults and a few small kids at most) but it is a decent model and runs $350 currently which makes it the only reasonably priced inflatable in the US right now (all the others are $600 plus IF you can find them in stock).   They are out of stock online, but if you put in your location you can sometimes find them in stock at your local walmarts (it's how myself and several others have found them).  

 

Here is a review of mine for those who are interested:

 

 

Link to post
Share on other sites

Hi All

I’ve just had the same fault with my hot tub. I’ve stripped it down and found that the heater element is actually working fine! I’m suspecting it is either the sensor in the pump housing, or a fault on the PCB. Will check these later today and post what I find.

If I cannot resolve to work correctly, I am going to run the heater direct from the mains electric by means of adding another power cable. That would be a quick fix.

Link to post
Share on other sites
On 5/25/2020 at 3:30 PM, Java said:

Did any of you have any luck?  Mine was working great until the FC started flashing. I then disconnected the power to change filter. When I plugged it back in, nothing lights up at all. Any ideas?

That may sound silly, but just in case. FUSE?

Link to post
Share on other sites
On 6/25/2020 at 12:07 AM, CrissyB said:

Has anyone tried a submersible heater? I found one on Amazon and I am wondering if it would work for this. I am getting the impression that this is a crappy hot tub. I only got 2 1/2 months total with mine. The heater died two days after the one year warranty.

Same here got 3 months

9 hours ago, Kevjmic7 said:

That may sound silly, but just in case. FUSE?

Is there a fuse? Where is it located?

Link to post
Share on other sites
  • 4 weeks later...

Hi everyone, I have the same issue here.  How do you even access the heater?

The retailer (on eBay) is not helpful & e-mails to SERVICE@FIRSTSPAUSA.COM go unanswered.  Anyone found a solution?  How do you contact Costway?

i'm in UK

thanks

 

 

Link to post
Share on other sites

Hi. I have a goplus as well. Mine is working fine, (knock on wood), but I want to ask you all, if you had left your filter pump and heater on constantly? I’ve had mine on ever since I bought it, which was in April. 
I’m seriously expecting the thing to not last a year, but would sure love it to!! Thanks for your insight ahead of time!

Link to post
Share on other sites
  • 1 month later...
On 6/12/2020 at 3:00 PM, Suzyqsjewelry@gmail.com said:

I have the same inflatable Hot Tub, My heater stopped working this year. I took out the heater, it is pictured just like the one above. I see my heater element actually split open. I called the GoPlus company, they told me they no longer sell replacement parts. I have searched all over the internet and have not been able to find any replacement parts. Was told by Go Pus that I just need to buy another hot tub.  Was wondering if anyone else have been able to fix their hot tub. Thanks

 

Link to post
Share on other sites

My name is Charles Compton and mine wife and I had order a GoPlus hot tub back in April of this year 2020 and we had it a month and the heat stop working so I contact the Company though Amazon and told them that they need to send one out to fix the problem and they told me that they don't have anyone to send and that I need to take it to somebody to fix it so me and my wife took it to a spa place and the check it out and everything was working the why it should be but they didnt have the heat element for my hot tub and after we got back home and I contact the company they told me that they was sorry and to throw away the hot tub I told them I want my money back or else and they send me my money back I keep the hot tub and now the buttons and the display don't work now the lonely thing that works is the jets and I have to reset the switch on the plug very time I or my wife wants the jets to work what a P.O.S company that GoPlus is

Link to post
Share on other sites
  • 2 months later...

Goplus heater element kawaii 1805 is cheaply made and fails, usually within a year. Ours did. Direct Replacement not available. Got a Camco 1000 watt screw in element, Pipe flange to fit, altered the six screw top to accommodate it, ring terminals to connect the power wires to the element, hole in the top of the cover plate, assembly, first time in the tub was good...

  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...