Jump to content
Sign in to follow this  
moscafj

Help identifying part and solution

Recommended Posts

The attached picture shows a box at the rear of the spa controller on my Jacuzzi J-335.  You can see in the picture that the plastic barb fitting has broken off inside the black box (lower right).  Also pictured is a similar attachment point/port at the top of the black box.  Firstly, any help in identifying these parts would be appreciated.  Second, I have tried a couple of methods of extraction, but can't remove the remaining, male part of the barb fitting from the lower right port.  It is threaded, right? Any tips for removal?   Finally, I don't think there was anything attached to the port on top.  Would that make sense?  I would appreciate any advice in how I might get this back together...or what I should replace to get up and running.  This is a J335 spa controller dated 6/3/08.   Thanks.

fullsizeoutput_a.jpeg

Share this post


Link to post
Share on other sites
Quote

 

What happens when you unscrew the screws at the 4 corners and slide out the part?  If it's broken anyway, what do you have to lose?

Share this post


Link to post
Share on other sites

I can access the two pictured in the foreground,  the two on the other side are hard to reach.  I believe I would have to remove the entire controller for that, which I was hoping to avoid.  But, it might be coming down to that.

Share this post


Link to post
Share on other sites
16 hours ago, moscafj said:

You can see in the picture that the plastic barb fitting has broken off inside the black box (lower right).  Second, I have tried a couple of methods of extraction, but can't remove the remaining, male part of the barb fitting from the lower right port.  It is threaded, right? Any tips for removal? 

fullsizeoutput_a.jpeg

The port at the top might just have a plug/block-off screwed into it, ignore that at this point.

To me, it looks like there's plenty of access to get to that busted-off male hose barb.  At hardware stores there are tools called "nipple extractors" (trust me on this one, I know nipples !!!) for extracting these.  There are different sizes (no jokes here !!!), get a set or one that fits.  These tighten in, and then you extract the broken part.  Also, a plumber could do this if you'd rather pay.  You should NOT have to re-tap the broken part either, it should come out; it likely was installed using some pipe dope or PTFE/teflon tape, you just need a nipple extractor to grab it...

Share this post


Link to post
Share on other sites

Yes.  Tried that.  It wouldn't budge and I was afraid to force it.  I have since removed the control panel to gain access.  Turns out, it is the heater assembly.  I've removed the entire assembly.  The pic is a close up of the stuck male end of the hose barb.  The grooves you see on the inside are from the earlier, attempted removal with the extractor.   The question remains, could this possibly be glued in?  Now that it is out, I am going to give it another go with the extractor.

IMG_4067 (1).jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×