Jump to content
Sign in to follow this  
CaffeineFlo

HotSpring Envoy NXT (2014) Remote Suddenly Dead?

Recommended Posts

Hi!

I got a HotSpring Envoy NXT back in 2014 that has worked great until yesterday when I took off the remote, trying to set the temperature.

Initially everything worked until the display went dimmer and dimmer by the second until the display was fully out. Touch controls did still work with a blank screen. I removed the battery then trying to see if water went in or something, but all seemed good. 

Upon assembling the remote back together, nothing works anymore with the remote. The lights and jets button on the panel still work, but nothing on the remote.

Any clues what it could be?

Apart from that, I'm wondering if there's any way to change the temperature on the control panel without the remote? Has anyone decoded the MiWi signal from the remote so I could rather control my spa another way?

 

Thanks

Share this post


Link to post
Share on other sites

Get a Free Hot Tub Quote

Save time and money by receiving multiple, independent quotes for a hot tub.

You may just need a new battery for your remote. The remote is the only way to change the temperature on the spa. Contact a dealer for service and see about a new battery.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×