Jump to content

BP500 vs BP501 (replacement)


Recommended Posts

I have a hot tub made by Clarity Spas. Breaker kept tripping so upon inspection, the control board (not sure of proper terminology) had a short connection on one of the power wires and roasted the board beyond saving. It was a BP500 model. I did some research and could not find a replacement bp500 to save my life. In reading and reviewing it appeared as though the BP501 would work as a replacement. I got the BP501 and have installed it. It works, but not all functions are right. I installed it, the main pump and auxiliary pump worked to purge the air out of the lines. I then turn off the purge start up mode to get it to begin heating and the main pump which either runs the slow speed to just heat while not in use, or the high speed to control half the jets isnt working right. The slow mode works and appears fine. When i hit the button to turn the jet mode on it makes a loud noise like the pump is seized or something then stops. The auxilary jets work great. I swapped the connections for the pumps to make sure it wasnt the pump, and the high speed on the main pump works fine. Therefore its something with the board i guess.

 

Anyone have any ideas?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...