Jump to content
Sign in to follow this  
Hooked62

Air control valves..1989 Hot Springs Grandee

Recommended Posts

I have water coming out of one of the air valves? Is this caused by a failed jet? Also the moto-massage dosen't "travel" I have new units on order , one had a hole in the water line but the air tubes on both units seem to be ok. Inlaws bought this tub new and I have had it for 15 years or so. Moto-massage have never really worked right but I let it go. Last week I lost a heater element and of course replacment elements can't be found. So I did some shade tree DIY and got heat again, changed seals on jet pumps and waiting on new Moto units. Hard to find any diagrams that help explain how the air system works.  Thanks for any hints or links.

Share this post


Link to post
Share on other sites

A little update..took the control valves apart and found 5 of the 6 filled with sand? not sure, a white grey layer tightly packed, about 1/8 inch thick that I think would be blocking alot of free air flow.I haven't seen any kind of "filter" or screen that would be what this "stuff" is. Also the new Moto parts just got here too so maybe by Saturday I can have everything back together and working!  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×