Jump to content

No power after switching off at breaker yesterday

Recommended Posts

I acquired a used Catalina Spa this year that needs a few small repairs. I got it moved into position last weekend and installed the electrical... (Main -> Exterior Sub with GFCI breaker -> Tub via conduit).

I kicked the breaker on and verified expected voltages at the Spa Pack, verified the control panel worked, verified the blower worked, and verified the high speed pump worked (we already knew the low speed pump needed repair).

I kicked the breaker off again and ordered a new LED light, and a start/run capacitor for the dead pump (I figured it was worth $15 to try before ordering a new pump). The light arrived first so I installed that, kicked the breaker on and verified the light. Then I kicked the breaker off again. 

The capacitor arrived yesterday, so I installed it on pump 1 and kicked the breaker on... now there is no power to any of the components, including the low voltage control panel. The Spa Pack makes a clicking noise once, about 1 second after the breaker is switched on. I tried unplugging all components from the Spa Pack and kicking the breaker on but it does the same thing, so I don't think any of the components are shorting out. 

Any ideas on what happened? It's about a ten year old tub, so I'm sure the Spa Pack could have finally kicked the bucket... but it didn't show any signs of failing during the previous days test.

Thanks in advance!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now