Jump to content

Fuse for Balboa Board


AlanL
 Share

Recommended Posts

Hi all, hoping someone with technical experience can be of assistance here. 

I have a Master Spa Twilight Series 8.2. Recently the #2 pump has had some trouble starting when called for. It will make the sound of a seized motor and trip the breaker.

Fixing the pump isn't the issue here. I have been resetting the breaker and cancelling the #2 pump when it's called for (about 1 minute into the start up cycle) in order to keep the water circulating and disinfected until I perform the pump repair.

The problem is that the control board seemed to stop functioning and when I looked into it, the fuse that protects the pump relay had blown. This fuse is an SC type, 30 amp/1000 volt which I cannot find anywhere. I went to an electrical supply outlet and the fellow there said that he couldn't match the fuse with any of the thousands he has in stock, but he also asked why it would be a 1000 volt fuse. The pumps are 230 volts and the relay should be a simple exchange of voltage over the circuit. 

This dealer has 30 amp/600 volt fuses and I'm just wondering if that fuse will do the trick, or are there other concerns? 

Thanks, 
Al

 

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...