Jump to content
BrianHardy

Nordic Retreat jets won't shut off

Recommended Posts

Apologies if this one is already in the blog, but I couldn't quite find it if such is the case. I have a 5 year old Nordic Retreat hot tub. It has 1 pump (no circulation pump).  It has a Balboa board.  I just moved it from someone's home to my home (5 miles), got it wired up, filled up with water and it is up to temperature (102 F). I live in southern Indiana.  My issue is the low-speed jets won't shut off even when it's at the set temperature. The manual says the low-speed jets will run until it's up to temp and they automatically shut off (and the manual says they'll also turn on automatically at times to bring the temp to the set point).

When I flip the breaker on, it goes into "priming" mode where the manual instructs you to push the "jets" button several times. While I'm doing this (and just holding down the "jets" button"), it will cycle through the high-speed, low-speed and off speeds of the jets. So, I know the jets can be in an "off mode." After a few seconds, I stop holding down the "jets" button and leave the jets in the "off" mode. The jets will stay off for a few moments, but then the low-speed jets automatically turn back on again.  I can cycle from low to high-speed during this time, but can't get the jets to shut off.  I would prefer the jets be off when the hot tub is not in use.  I have set the filter cycle to the lowest setting (F1). 

Nordic Retreat board.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×