Jump to content
TheWGP

2002 Caldera Paradise Martinique replacement board and topside

Recommended Posts

So I've posted a couple of times about our 2002 Caldera Paradise Martinique.  We've replaced heater relay boards a couple of times now, and the topside has some sections of the display that are shot.  We finally ended up with an apparently intermittent lack of heat that would be fixable for awhile with a reboot, but ultimately would result in a blinking red light on the heater relay board and no power to the heater.

I diagnosed these as relay failures - then this last time, I happened to notice the temperature display when it was supposed to be HOLDING temperature - and it was dancing around!  When the temperature was set higher than the water temp, it would heat just fine, and when the temperature was set lower than the water temp, it would turn off just fine.  But - when it was supposed to be "holding" then the topside displayed shifting temperatures (because of the display issues, not sure what exactly).  I then also noticed that the relays were clicking on and off in quick fashion - once every few seconds.

I have replaced the hi limit sensor and the temp sensor both, and have also jumpered the pressure switch.  No change to any of this behavior.  Thus, I concluded that the topside or board were probably bad.  I saw a post or two on these forums about bad topsides once in a great while causing intermittent problems of this nature - however, given the age of the tub, the replacement topside available online was listed as often incompatible with the older boards, with replacement of both board and topside recommended.

Obviously that was cost prohibitive, so I debated just replacing the heater relay board and using the breakers to turn the spa on and off, since I concluded that the every-few-seconds on-off on the relays must have been what was causing the issue, and I could at least fix that and try to reduce the wear on the board.

 

Lo and behold... ebay to the rescue?

https://www.ebay.com/itm/Caldera-Spas-Pure-Comfort-Spa-Pack-Controller-Topside-Keypad-Watkins-974701/222967700249

I got this and it arrived in apparently good shape.  The board seems to be the one that's recommended to replace mine, and as this topside/board combo were working previously I am hoping for no further issues there.  As a bonus, the heater relay board was also included so I'm just going to replace the whole box.

 

I am certainly capable of making all the switches in connection, etc. and will be quite careful to hook everything up correctly.  That said, two questions:

 

1) is there anything I should know before starting this "full box swap" as it were?  As best as I can tell, it seems this should work.

2) the sticky gasket on the bottom of the "new" topside is broken off in part - I assume when I remove my old topside it will have similar issues - is there something I should do underneath/around the topside to prevent water infiltration, or do I have to try to find a new gasket somewhere and clean the old one off the "new" topside and the top of my spa?

 

Thanks in advance for your thoughts!

Share this post


Link to post
Share on other sites

Get a Free Hot Tub Quote

Save time and money by receiving multiple, independent quotes for a hot tub.

So just to update... this went well!  

 

To answer my own questions, for the benefit of anyone who may read this in the future:

- be very careful labeling each wire - I caused myself much unneeded stress and odd behavior of the tub by accidentally flipping "blower" and "circ pump" wires.  

- the plastic tabs holding each connection on can be delicate - I inadvertently broke one on my old board pulling the sensor plug off.

- the "program" jumper on the new board was a little different for the Martinique than my old board was - not a problem, works fine, just don't blindly copy it

 

The sticky gasket - cleaned it off easily on the "new" topside.  I then pried up the old topside with a pennknife and a very thin screwdriver.  Following that, I scraped the old silicone remnants off, and I applied a new bead of silicone caulk underneath the topside, and then another bead continuously around the outside of the new topside.  Seems to hold it in place fine, and keep water out, which is the important part!

 

I would encourage anyone thinking about this type of replacement to be very careful and do your homework on it - but it's certainly possible to do even large scale replacement projects like this yourself.  

In the end - this has been running for a couple of weeks now and is 100% successful thus far - we now have a fully working display, no intermittent heater stop-starts, and overall our hot tub is the best it's ever been.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×