Jump to content

Jetsetter Leak, Mystery and Intrigue


Recommended Posts

I’ve got a 2004 Hot Springs Jetsetter that has been relatively trouble free until recently. Last month, a few days after  water changeout, the level had dropped about 9 inches and I saw water leaking from below the spa in the back right corner in the vicinity of the motomassage.

There was no water in the equipment compartment, so I scheduled a visit from a Hot Springs tech thinking it might be a quick diagnostic/ fix. No such luck. He came out, told me I had a leak and would have to drain the spa, move it away from the house, refill it, reheat it, and have him return. 

I drained, moved, and refilled the spa. I didn’t replug it since I was heading out of town for a week. When I returned, I replugged it, but did not check the water level. I’m thinking this may have been my first critical mistake. Or not. Did low water cause what happened next?

The next day I glanced out to see if the spa had gotten to temp. There were no lights on the Control Panel. I checked the GFCI and it had tripped and would not reset. Checked the breaker in the house and it had tripped. Reset that and then reset the GFCI. The light on the GFCI glowed red so I assumed all was well. But there was no power getting to the spa from the 125v cord, so assumed the GFCI was toast. I replaced the GFCI, tested and confirmed it worked properly. There now is power getting to the main bus on the heater board in the equipment bay, but still no display on the Control Panel. No power from the main bus to the main board either. So I assume that the heater board & possibly Control Panel are toast.

But I still have the leak to trace. I’ve pulled off most of the back boards and a few of the side boards. Found some soggy foam and kept digging but all led to dry foam. I can see water pooling in the back corner, but have not yet been able to follow it to the source.

Tomorrow I will add some food coloring and be back to digging. The water is still leaking, however the level is dropping verrrrry slowly now- maybe 1 inch over the past 10 days. I’m assuming that’s because the circ pump is no longer working. But maybe not.  If the food coloring doesn;t help to find the source, I'll likely drain and try to raise the tub so I can attack it from underneath.

My plan is to keep trying to find the leak(s) and get that repaired first. Assuming that’s successful, the next steps are a bit of a mystery. So here are my questions:

1. Any hints on how to better track down a leak or is it just tedious trial and error?

2. Is there a logical way to test the Heater & Main Boards to confirm either is fried or not?

3. Is there a way to test the Control panel to determine if it needs to be replaced?

4. Are there things to check prior to replacing either Board &/ or Panel to ensure they don’t self-destruct again? i.e. what might have caused one or both to fry?

5. Can I bypass the board and energize the circulation pump to get some pressure into the system to help track down the leak(s)

6. Is there a better way to try to salvage this tub than what has been outlined above?

It's been a great tub and I'd replace it with the same if we weren't planning to move in the next 2-3 years. Anyone want to weigh in with some suggestions and tell me I'm wasting my time?

Link to comment
Share on other sites

UPDATE: The leak has been found!

Whether this is the only leak or not remains to be determined. The leak that *finally* presented itself is a broken nipple at the bottom of the MotoMassage. Not sure if I'll have decent access to repair this with the spa down, but should be fairly simple with the spa on its side.

I've plugged the nipple and the hose and will fill the tub tonight to see if there are any other leaks to address. Six hours of foam excavation is more than enough. I do hope there's no more to be found.

Electrical questions above remain, though. Would a fried heater board keep the Control Panel from displaying anything?

Link to comment
Share on other sites

  • 2 weeks later...

Gee, I think I'm just talking to myself ;)

No further leaks found. Drilled out the broken nipple with an M size bit and used PVC transition cement to glue in the replacement. Had to lift the spa to come in from below in order to get the proper angle/ space for drill to clear. Clipped off 1/4 inch of brittle tubing at the end, heated the new end and attached.

New main board replacement was pretty straightforward. Thankfully, the heater board was not damaged and Control Panel lit up once power applied.

Thought about adding silicone to the repaired joint but after 48 hours of testing under heat and running jets a few times decided to leave as is.

Filled smaller "excavations" with larger foam pieces that had been removed and topped with Great Stuff Gap filler. Stuffed bubble wrap in the open cavity around the repair and added some Great Stuff at the back for a solid close. Hot glue and foam now keeping the boards attached. Not sure if that's a long term fix but time will tell.

Very nice to have the tub up and running again!

Link to comment
Share on other sites

  • 8 months later...
6 hours ago, alaska_guy said:

Would you mind letting me know where you got the replacement part and what M type bit you are referring to?  I assume you mean drill bit for metal?

Thanks in advance!  I am having the same issue.



The replacement parts came from Backyard Plus. You'll need a Bleedline Nipple http://www.backyardplus.com/proddetail.php?prod=30598 and Spring Clamp http://www.backyardplus.com/proddetail.php?prod=31134. You can probably reuse your spring clamp, but since you're going to the trouble of fixing this, spend the extra $1 and do it right.

I also needed the Motherboard http://www.backyardplus.com/proddetail.php?prod=77087 for the electrical problem. Hopefully, you don't have that problem as well. 

 The M bit came from Grainger. https://www.grainger.com/product/WESTWARD-Jobber-Drill-Bit-2UFT4  It is very similar in size to a 19/64 inch bit. I'd never heard of an M bit before, but picked it up since that was supposedly the exact diameter bit needed. The "M" refers to the size, not metal and you only need it for about 3 seconds to drill thru plastic. I came in from the back in order to preserve the angle, which meant digging out more foam.

Good luck!

Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...