Jump to content

Watkins No-Fault 6k Heater Quandry


chadwood1
 Share

Recommended Posts

Hello,

I bought a house 1 year ago, and it came with a HotSprings Grandee Spa, which worked great even after I refilled it back in April 2016.  From the looks of it, it was manufacturd in 1999 or 2000.  Anyway, I recently refilled the spa, and noticed that the heater wasn't working.  TO be honest, I am not sure if the heater had been working before the refill, or if it stopped once I'd refilled it, because we hadn't used the spa in a couple of months.  When I reset the heater, it clicks and clacks, I can see water moving through the inlet and outlet lines, but it kind of moves back and forth.  Then, the high limit sensor trips, everything shuts off, and the power light flashes until I turn the breaker off for a minute or so, then turn it back on.  

Here is what I have done so far, for troubleshooting:
1. I tried resetting the spa and heater, with the filters removed.  

2.  I checked the water line coming from the heater for blockages or air...when I loosened the hose, water flowed freely from both the heater end, and the spa end.

3.  I checked the voltage on the heater relay board, and it was perfectly fine.

I noticed that when I hit the reset button on the heater, I hear the sound of water flowing, I see water move through the tubed going to and from the heater, there is clicking and clacking, the green "ready light" lights up, for a second, then the high limit sensor trips.  What do you folks think?  Is it the entire heater?  THe high limit sensors?  The thermostats?  A blockage of buildup somewhere?  I'm hoping to diagnose this without having to hire a tech.  Putting this out on the forums is my last resort.

-Chad
 

Link to comment
Share on other sites

There's no water moving through the system, upon closer inspection.  The tubes to and from the heater are slightly translucent, and you can see water just sitting in the lines.  My guess is the pump isn't doing its job, so the pump heats up stagnate water until the high limit trips.  When I reset, the pump engages, water shoots back and forth, and then it sputters out, and the high limit trips.  While on, it just hums.  I tapped it with a wrench, and the hum changed a little bit, but nothing engaged.  It's a fairly old silent flo 5000 pump.  Probably needs replaced.  I did some more troubleshooting after I posted this, and now think the circulation pump has gone off.  Someone correct me if I'm wrong.  Thanks for the reply!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...