Jump to content

Recommended Posts

Hello all, looking for help getting my 2006 H2X Master Spa working. I'm new to having a spa tub, but a pretty crafty guy. 

Here's the situation:

Moved the tub from Indy to Louisville, KY. Got it placed and electric hooked up. Filled it and for the first week nothing came on, finally realized I had the breaker terminated wrong. Got it working today,(it's 30 degrees here), and I'm trying to make sure nothing's frozen and/or broken. Looks like all the pipes are ok although I have a little leakage from one of the shut off valves from pump 2 but it seems to be running fine and circulating water through the standup jets. 

My screen is throwing a DR code, I cycled through 3 times and now it's showing me a DY Code. The manual says the DY code is  Inadequate water detected in heater, Pump 1.

Pump 2 seems to be cycling water through, Pump 1 doesn't even spin, and when you press the heat button it tries, but then clicks off (I can hear the click in the control unit)I'm wondering if their's air in the line or if there is ice in the line preventing water to flow into the heating element. I'm also wondering if I need to prime pump 1? Do I need to by a new pump? 

Additional info:

Filters were cleaned,

I haven't put any chemicals in yet, (should I?)

I have pics, but it wont let me upload.

Pump 1 is a Balboa 56FR, 4.5HP, 2 speed, 240, 10amp, model DJAYGB-3155MB, I've found one online for $455. 

I haven't even looked or tried the swimming cycles and pumps yet, anything i need to look out for here?

 

Any help would be awesome, I'd like to get it running and heating asap or I will need to drain it. 

 

Edited by louisvillediddy
made it more clear
Link to post
Share on other sites

Update.

I did prime the pumps to try and get any air out, but it seems like there was plenty of water coming out, and I didn't hear the hiss I was expecting from a possible air block. I also checked the shaft of pump one and it wont turn. It has a little corrosion on it, but was assured by the previous owner that it worked up until the day I got it. I'm wondering if I need to replace the motor? Do I take it out and check it by hand? I can hear in PR mode it try to click on but it doesn't turn....

I found this, would need the 56FR version... 

http://bathandspaparts.com/djaygb-3155mb.aspx

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...