Jump to content

Slice Valve Location Twilight Series 8.2


AlanL
 Share

Recommended Posts

Hi people, I purchased a used TS 8.2 spa and have it set up and running, however I have found a leak at the #2 pump coupling. I have tried to tighten the connection but it did not appear to help, at this point I would like to disassemble the connection to obtain a better view of where the issue is, but I cannot seem to locate any relevant slice valve to isolate this pump, there is a slice valve at pump #1 and another at the heater element. Is there perhaps another buried under the mass of insulation? 

Any help would be greatly appreciated, 

Thanks, Al

Link to comment
Share on other sites

Thanks for the reply, I didn't think it made much sense that a valve would be buried within the foam insulation but OTOH, it also doesn't seem right that there isn't an isolation valve beside the pump. Good to know about the collar, hopefully I won't need one, but just in case :mellow:

Link to comment
Share on other sites

I went ahead and turned off the two valves that I could see and proceeded to remove the coupler so I could replace the seal. Ended up draining the entire tub (465 gallons) :lol: All good though, the new seal stopped the drip and I didn't require a new collar. The tub is just reaching the the 96 degree mark, should be good to go in an hour or so, thanks again for the help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...