Jump to content

Strange Pump Behavior & No Full Power Jets


Firm
 Share

Recommended Posts

Hi Everyone,

I just joined the community here looking for some help with my hottub which started acting weird. I *think* I mostly likely need a new pump, but I figured I'd post and get some opinions first.

It's a 2010 and the spa was made by a company called Strong Spas. It has a Balboa Revolution (TP600) control system and a Water Way pump (model # PV-30-2N22C). I don’t know much more than that as the tub came with the house.

Anyway, it’s worked fine for the last 3 years that we’ve had it. Today we went to use it and when I opened the cover the low power jets were running, I figured it was either heating or filtering, so didn’t pay much attention. I hit the Jet button again to turn on the full-power jets and the pump made a loud grinding/hum noise and then shutdown. If I hit the button again for low pressure jets they’ll come on and run normal, but as soon as I try to turn it to full power jets the pump makes a noise and then shuts down.

I took the side panels out to investigate and couldn’t find anything obviously wrong, although the motor does seem to be running hot. I turned off the main power and left it for about 4 hours, then turned the power back on and tried again with the same results.

If I watch the pump when someone else turns the jets up I can see it running normally, then as my wife hits the jet button the pump does step up to full speed (although noisy) for about 2 seconds and then shuts right down. If I don’t touch anything after it shuts down, every minute for so it’ll start itself up to full power, run/grind/hum for the 2 seconds and then shutdown. Turning the jets back to low power the pump resumes normal operation.

So far my thoughts are:

-Capacitor on the motor is too weak to get the motor to full speed – maybe not likely since it does run at full power for a second or two…

-There’s a faulty pressure switch somewhere that’s shutting the pump down thinking that it’s dry (it’s not – I’ve checked and there doesn’t appear to be air in the system, and the water level is where it should be)?

-The pump itself is bad/worn out and it putting itself into some kinda protection mode whenever the jets are turned up?

Any help or advice with this is much appreciated.

Link to comment
Share on other sites

I think you may be right!

Last night I had left the main power off and tried it again in the morning....It was still acting as described above, but this time I heard a load click come from the controller whenever I hit the jet button. I called my wife over and had her hit the button while I tried to isolate the sound, as soon as I touched the controller the full jets came on. Since then it's been acting fine, although I expect it to start trouble again soon enough...

When it does, is the controller a serviceable unit? If it is, any idea what the fault inside of it might be?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...