Jump to content

Recommended Posts

I have a Tiger River Spa, the Sumatran N model. Recently, the water went cold, and I could not get it to heat. After following threads and discussions in this site and others, I tested and was able to determine that the heater was bad. At that point, everything else in the spa worked, and no circuits had been tripped. Jets ran, control board worked, main circuit board green light and red light both lit. The failed heater was a Watkins No Fault 6000 with the following information on the sticker on the bottom of the unit: 240V6000W, THJ01, SET-DO-OH-CO, 11113, 240328, 36(8?)10 REV K. The replacement heater, as recommended by Watkin's, is a Watkins PDR Titatium 1.5KW/6KW - model #73790. I drained the tub, replaced the heater, and then refilled the tub with the filter removed and the hose in the filter housing tube to reduce the chance of air locks. I then replaced the filter, turned the power back on, and purged the pumps by turning the jets on and off. Everything appeared to work properly. I then added a bottle of the enzyme mix from Carefree Spa, called Le Natural Spa, which I have used for the last 6-8 months. Per instructions, I removed the filter, and added the solution to the filter housing. The instructions then called for me to circulate the spa for 15 minutes. I turned on the jets, and went about cleaning up. After about five minutes, the jets stopped. The jets "on" icon was still visible on the read out on the control board, but no jets operation. I tried to turn the jets off and then on, but to no avail. I checked the circuit board and no circuits had been tripped. I then cut the power to the spa at the circuit board, and let it sit for 30 minutes or so. When I powered it back up, but the jets would still not kick in. Instead, there was a clicking sound from the circuit boards, and I noticed that when I first pushed the jets button, a small green light would light at the very top of the smaller relay board, and then it would click and the very small green led light went out and the small red led light next to it would come on. Previously this had been a constant green. I tried turning off the heater at the circuit board, to see if the jets would then work with the heater out of the mix. That did not work. It was getting late, so I let the tub heat overnight. The heater brought the water temp to the set temperature during the night. In the morning, I went out and tried the jets again, and they came on, but once again after a few minutes they shut down. I have powered the spa down from the main circuit box and let sit for 30 minutes before powering up again, to no avail. At this point, all I get is the above described clicks and shift from the small green to red led on the top of the smaller relay board. I also tried inserting the hose with water turn on high into the filter housing tube to remove any air locks. Any ideas anyone?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...