Jump to content

"blinking Power Light" - Help


ocho
 Share

Recommended Posts

I have Tiger River hot tub- I am guessing it is an 02 or 03 model. The tub powers up then after a couple of hours the red Power light starts blinking and it stops heating. I reset the breakers and it works for a while and then the same thing happens. The more often that I do this the shorter the duration between the resetting of the breakers and the “Blinking of the Power light”. Maybe because the water is getting warmer in the tub? The tub never gets to the set temperature (maybe 10 degrees shy of it).

I tested the thermistors- they were still good

I have replaced both thermistors – same results

I force purged the tub with a garden hose through the gray standpipe- same results

I replaced the circ pump (The new one is considerably stronger) – same results

I double checked that I didn’t have an air leek or air bubbles in the circ pump.

The tub has a stereo- I have removed it and the its ac/dc convertor.

I have removed the filters and tested it – same results

If anyone has any advice on the next steps to diagnose this problem it would be greatly appreciated.

Link to comment
Share on other sites

When the red light flashes next time, remove the IQ2020 control box cover, and look for 2 very small led's labled "lim OK" and "cntrl unplugged" If control unplugged is lit, you have a comm error- likley the stereo, or something esle on the I2C interface (The large 10 pin harness), or a problem with either the control head or IQ2020 main PCB. If the high limit is tripping (lim ok not lit, but neither is control unplugged) it's likely due to low circ pump flow, or hardness buidlup on the heater, or some other flow issue. It will help you isolate the nature of your problem. It could be as simple as unplugging the stereo.

Link to comment
Share on other sites

That's great. How is the circ pump flow? It may just be a slightly clogged filter. 1st step is to remove the filter caps. You don't need to take out the entire filters. Once you remove the cap with the open standpipe, that's the one that's dedicated to the circ pump. Put the other caps back on, leave that one off. See if the problem dissapears.

Link to comment
Share on other sites

The circ pump flow is good. I replaced the circ pump last week. The new one is conserably stronger than the old one was.

Problem still occurs

The last 2 nights I have removed the filter and reset the tub.

Problem still occurs- I wake up to a red flashing light.

Link to comment
Share on other sites

  • 2 years later...

Revival! 

Did you ever resolve the issue?

I have the same problem going on. But mine only runs and heats for 5-10 minutes then the power light starts flashing and the heater stops working? If I keep the jets running it will run and heat until the jets time out.... any ideas? I'm not around the tub now, but will check the lim ok and control unplugged lights.  How do you test the thermistors?  

Link to comment
Share on other sites

Tonight I got home and the power light was flashing again... So I flipped the power off them back on again, I then turned on the jets as that is the only way I can get it to stay running. So we went out to sit in the tub and it was at 110 degrees?! Not sure if that's normal?? But anyway, i shut the jets off and the power light stayed steady??? But as soon as the temp came down enough and i could feel hot water coming out of the grate again, the power light started blinking again. 

So it seems as soon as the heater comes on the light starts blinking and shuts everything down. 

I unplugged the "limtherm" thermistor and reset the breakers- this makes the light blink immediately after I reset the power. 

Next I unplugged the "regthermistor" and reset the breakers- this makes the ready light blink after a few minutes. 

Im at a loss?? Does the heater have a little hardness build up in it?? And if so how do I clean it out? Or do I need a new heater? 

I should add that I tried to run it without the cap on the filter with the same result. 

Any info for a fix would be greatly appreciated! 

 

Thanks

Alex 

Link to comment
Share on other sites

I am have the SAME EXACT issue with my 2007 Hot Springs Envoy.  I replaced a GFI early Spring.....replaced the heater in the Summer....now still blinking red power light after a while powered up.  Never seems to reach...or just reaches the set temp ...then trips.  Techs are raping me with services calls only for them to finally tell me its MAY BE the Hi Limit Switch OR the Circulation Pump.  I'm not paying these guys to come back another 3 or 4 times at $150.00 a pop.  Anyone have any ideas what the problem maybe?

Kelly G. - Johnson City, NY

 

Link to comment
Share on other sites

Take that back.... ahhhhh! Why are these thing so touchy?!?!  Ran great for 4 days since I posted the above reply. Then the power light started blinking again out of no where. I think my heater has some build up in it?? As it makes a hissing noose when it's running. Like its just on the verge of boiling water? 

 

Anyone have any great ideas for cleaning build up out of these heaters?? 

Link to comment
Share on other sites

  • 2 months later...
  • 1 year later...

Hi did anyone solve the problem, I have the same issue, my limelight flair heats up and all seems ok then the power light starts flashing, if I turn it of at the mains and on again it works but only for a while, the heat stays the same so it still stays at the right temperature even when it’s flashing

Link to comment
Share on other sites

  • 10 months later...
  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...