Jump to content

Recommended Posts

I have a Caldera Geneva that was working fine but my wife noticed that it went into the daily clean cycle and never came off. She powered it off at the breaker. I powered it on today and when you power it up and the clean cycle starts it never stops. It does not show it's in clean cycle but assuming that's what's happening. About 1 year ago we had a similar issue where it ran continually and would heat until you shut it off. I had to replace a conrol board.. I thought maybe a relay is sticking? any idea where to start troubleshooting?

Thanks,

Fred

Link to post
Share on other sites

Pulled the Heater Relay Circuit board and all looks fine.. Pulled the main control board and it looks good too. I did find that the ground going to the heater relay circuit board was not "tight".. The spade connector was not what I would call a tight connection. Cleaned all the connections and re-assembled and so far it's working normally. Not fully up to temp yet but I set it lower and heat cuts off. All motors cycle as they should.. Keeping fingers crossed.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...