Jump to content

Salt Tub Frustration


Monett
 Share

Recommended Posts

We have had a Hydropool 495 model with salt system for 2 years. It has been very fussy and hard to keep clean. I feel like we are out there every other day checking the levels and adding chemicals or taking water samples in to be checked at our local spa store. There is nothing easy about this hot tub. This past 6 months were the worst and we had to put bromine pucks in just to keep the bromine up. We thought it was broken so we had a technician come take a look and he said it's probably the phosphate levels are too high. True enough, the water test showed phosphates off the chart. Through process of elimination, we discovered our well water was to blame for the high phosphates. So we emptied the tub on Sunday, checked the well water (now 6 months since we last emptied the tub, now a different season) there are no phosphates in our well water so we filled it up and did the regime of chemicals and salt. The tub was crystal clear, beautiful smelling, just gorgeous, for the first time in 6 months, and today - 3 days later - it is green and smells of alge. We tested it, and there is no bromine in the water at all. Does this mean that the machine is broken? Has it been broken all winter long? What exactly did the technician do when we called him out here at the beginning? - Oh and it's on filter cylce 8 if that means anything.

We are beyond frustrated and dissapointed with this tub. It was SO expensive to buy, and now maintenance is breaking the bank. If anyone can shed some light on this situation, it would be appreciated. Has anyone else experienced this problem with a salt tub?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...