Jump to content

No Pressure From The Jets


Recommended Posts

I have a VERY VERY old Leisure Bay hot tub that seats 6-8. No model # on it( bought it used). 7ft x7ft currently has a 1hp pump. Replaced O rings on jets, it had a new pump that flows well and circulates water nicely. However, water not going forcefully thru jets like our old hot tub. This tub has no BLOWER!!! it was disconnected. I dont know what size pump or blower is required on this size tub since I dont have a model #. Any help would be greatly appreciated. Thanks so much.

Link to comment
Share on other sites

Some models have 2 speed pumps... and the control board setup to recognise this.

meaning?? My control board is simple on/ off, heat and circulate thats it no read outs at all . Any idea how to check if somethings not working I dont even no what to check .

Link to comment
Share on other sites

The blower won't make any difference in jet pressure, not sure if that's why you want one?

No, just asking, I thought the blower was just for the bubbles in the seats right? Just wanted some trouble shooting ideas dont even know where to begin. Had 1 suggestion to check the impeller, to see if was worn down. The pressure is better closer to the pump side of tub.

Link to comment
Share on other sites

I'd guess the air flow control system is not working properly- or there's a broken check valve that's forcing the water through the "ozone jet" instead of the actual jets.

If you're getting massive flow through the ozone jet in the footwell, just cut out the 1.5" check valve on the pressure side of the pump.

If you're not getting any air out of the jets- post a pic of the jet, and we'll go from there.

Link to comment
Share on other sites

I'd guess the air flow control system is not working properly- or there's a broken check valve that's forcing the water through the "ozone jet" instead of the actual jets.

If you're getting massive flow through the ozone jet in the footwell, just cut out the 1.5" check valve on the pressure side of the pump.

If you're not getting any air out of the jets- post a pic of the jet, and we'll go from there.

Thank you for the suggestion , Ill try that and get back to you. I appreciate it. I checked the impeller and its all good.
Link to comment
Share on other sites

No valves on or near pump other that T valves used to turn off water flow to pump . Not sure what an ozone jet or footwell is sorry just an amateur with a owners manual or schematic.

The check valve is inline, and appears like a simple coupling, only it's a little larger. Look on the pressure side of the pump, and follow it past the slice valve- it's usually within three or four feet before the 1.5" flex pvc goes into the 1st manifold. Depending on the age- you may not have one. And it's only suspect IF the ozone jet is pushing FAR more than normal.

Otherwise- it's very likely the air flow control system- just need new jet inserts if that's the case.

Link to comment
Share on other sites

okay I found that valve, so the only way to shut it off is the T valve which is on the opposite side which will shut off all water going into the pump on the opposite side

All lines purged? How long did it set with zero flow?

All lines purged? How long did it set with zero flow?

Im sorry it never had zero flow it has no pressure from jets always had flow just limited pressure Thanks

Link to comment
Share on other sites

There may be a diverter jet in the tub. Turn pump on and then turn and twist all jets in the tub and see if thats it.

Also if u have no controls, the pump may be on low speed. Look to see if the pump has 2 rpm values on its sticker. If

It does then reverse the red and black wires either in back ofthe pump or in the pack, although high only on the heater will

likely overheat the water.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...