Jump to content

Recommended Posts

First off, whats going on,

I see that all my posts have been deleted and i could no longer log in.

Secondly, i see that Budge's posts have been deleted.

Is this true or am i missing something.

I hope no one is censoring our opinions.

The last message i got was from Tom on Friday afternoon and everything seemed ok, except that my

tub is still not fully working.

Just noticed that a lot of postes dated from Nov2nd to current have dissapeared.

Question.

With no Onzen working, how often should i put 'Refresh' into my Summit spa?

I have not used the Spa now for 12 days and the water is starting to create a film around the sides.

Any suggestions.?

Nigel

Link to post
Share on other sites

I know nothing about Onzen and don't have an Arctic Spa. However, since you are eager to use your expensive spa, I wonder if you could buy something like a bromine floater or a floating Spa Frog system until you get the Onzen worked out? Of course, you'd have to adjust your TA and pH and shock it first...but you already know that.

We are going to be buying a second spa for a second home and up until recently, I had Arctic high on my list. But there seem to be a lot of problems with Onzen. I know you guys will get it worked out and then potential future Arctic owners like me will have an easier time.

Link to post
Share on other sites
I know nothing about Onzen and don't have an Arctic Spa. However, since you are eager to use your expensive spa, I wonder if you could buy something like a bromine floater or a floating Spa Frog system until you get the Onzen worked out? Of course, you'd have to adjust your TA and pH and shock it first...but you already know that.

We are going to be buying a second spa for a second home and up until recently, I had Arctic high on my list. But there seem to be a lot of problems with Onzen. I know you guys will get it worked out and then potential future Arctic owners like me will have an easier time.

Its funny how you mention that, because when i was looking into purchasing a spa, the store sold it to me based upon the fact that all the kinks had been ironed out and they now have it down to a tee and Onzen is the best way to go.

Oh boy how i was caught up with the sales pitch.

Great quality spa, frustrating contents.

Link to post
Share on other sites

These are the words that are on Arctic Spa's website.

"The future of water care is natural, and easy on the environment. Arctic’s ONZEN™ automated water system combines patented ozone technology and natural sea salt into a single system that will save you time, reduce the need for chemicals, and allow you to enjoy soft, sparkling water with a minimum of fuss.

2 months into this and i'm still going through a load of chemicals, endless fuss and as for time saved, very much time lost.

Day 7, still awaiting for my Service call!

still awaiting for the store to call me.

Still awaiting to relax in my spa.

Nigel

Link to post
Share on other sites

Good news!

Arctic called me, a service technician will be coming out on Wednesday.

So i hope from Wednesday onwards all my posts will be of the positive nature.

Once my onzen cell is replaced / fixed i hope i can enjoy the spa just as the sales pitch says.

"save you time, reduce the need for chemicals, and allow you to enjoy soft, sparkling water with a minimum of fuss."

I really do hope it works, i do believe i did by a very good quality spa, with that said, i wish i had done more research on Onzen first.

If all goes well, i expect to be using by the weekend.

Link to post
Share on other sites

I want to merge all the onzen threads for better time management - it will give us one single place to look. Any objections?

Link to post
Share on other sites
Good news!

Arctic called me, a service technician will be coming out on Wednesday.

So i hope from Wednesday onwards all my posts will be of the positive nature.

Once my onzen cell is replaced / fixed i hope i can enjoy the spa just as the sales pitch says.

"save you time, reduce the need for chemicals, and allow you to enjoy soft, sparkling water with a minimum of fuss."

I really do hope it works, i do believe i did by a very good quality spa, with that said, i wish i had done more research on Onzen first.

If all goes well, i expect to be using by the weekend.

Nigel, you and I must be tied together at the hip:

My service guy is comming on Thursday, I had to beg to get this person rather then wait till next week. I hope that they replace my onzen because i believe it does not work. I am not hopeful though, and think that instead I will get the try this and this, etc, or you are right you need a new onzen, we will order the parts - see you in several weeks.

It is going on three weeks now, that I have effectively had a $12000 expendure sitting in my yard that is using up electricity and that I cannot use because of problems. I am getting quite frustrated.

If this does not get resolved quickly, I am going to ask for a refund so that I can buy a tub that works.

BMR

Link to post
Share on other sites

BMR & Everyone else.

My Spa is fixed!!!!

And yes it was in serious need of attention.

BMR, not sure where you are located but if you are in Ontario i hope you get the same guy we got, FANTASTIC!

Within seconds he found that the valves for the Onzen system were installed back to front, they were sucking rather than blowing.

He was suprised my tub wasn't green.

So, the people that assemble our tubs missed a major thing, he also mentioned they should of caught this during the testing, which they didn't.

Next, the Electrode was burnt out! that had to replaced.

Once all that was done he did a few other things to the spa that we hadn't noticed that should of been done at set up, but he did it and got us up and running.

We have never seen so many bubbles coming from the Onzen system.

He even mentioned that the install guys should of picked this up, the lack of bubbles.

So for the past 2 months we have been operating a poorly asembled Onzen system, wasted hours traveling to the store, lots of frustration and all it was, was poor Quality Service check at the factory.

Arctic Spa needs to get on top of this matter, this is clearly a factory problem.

It would be nice to recieve an appolgy from Arctic for sending me a faulty system and for my time and frustration.

These problems should of been picked up by the store themsleves after a dozen or so trips with water samples. Instead all they say is buy this and add more!.

The Technician spent some good time with us, explained a few things and gave us some good advise.

This technician was our saving grace, we were so close to losing it.

For two months we were made to think we were stupid and clueless when all along there was a major problem.

With that said, i still believe i bought a very good quality product but the back up service / customer service needs to be re looked at.

I will let you know how my tub is looking over the coming days.

He has me set at CP3, said i should not need to go higher for the two of us.

Nigel

Much Happier!

Note, future buyers, if you buy an Arctic Spa make sure they explain everything to you and at set up make sure everything is checked over.

The delivery guys were rush rush GONE!

Link to post
Share on other sites
BMR & Everyone else.

My Spa is fixed!!!!

And yes it was in serious need of attention.

BMR, not sure where you are located but if you are in Ontario i hope you get the same guy we got, FANTASTIC!

Within seconds he found that the valves for the Onzen system were installed back to front, they were sucking rather than blowing.

He was suprised my tub wasn't green.

So, the people that assemble our tubs missed a major thing, he also mentioned they should of caught this during the testing, which they didn't.

Next, the Electrode was burnt out! that had to replaced.

Once all that was done he did a few other things to the spa that we hadn't noticed that should of been done at set up, but he did it and got us up and running.

We have never seen so many bubbles coming from the Onzen system.

He even mentioned that the install guys should of picked this up, the lack of bubbles.

So for the past 2 months we have been operating a poorly asembled Onzen system, wasted hours traveling to the store, lots of frustration and all it was, was poor Quality Service check at the factory.

Arctic Spa needs to get on top of this matter, this is clearly a factory problem.

It would be nice to recieve an appolgy from Arctic for sending me a faulty system and for my time and frustration.

These problems should of been picked up by the store themsleves after a dozen or so trips with water samples. Instead all they say is buy this and add more!.

The Technician spent some good time with us, explained a few things and gave us some good advise.

This technician was our saving grace, we were so close to losing it.

For two months we were made to think we were stupid and clueless when all along there was a major problem.

With that said, i still believe i bought a very good quality product but the back up service / customer service needs to be re looked at.

I will let you know how my tub is looking over the coming days.

He has me set at CP3, said i should not need to go higher for the two of us.

Nigel

Much Happier!

Note, future buyers, if you buy an Arctic Spa make sure they explain everything to you and at set up make sure everything is checked over.

The delivery guys were rush rush GONE!

WOW !!!

I sure hope that my case is a similar issue. I am near Wonderland and hope to get the same guy you got, do you know his name? I am very dissapointed so far, as I too think that the product looks like it is a very good one, but if I cannot use it, what good is it??

My guy will be here tomorrow, I will post after he leaves, unfortunately I will not be here to see what he has to say.

I may have to take the day off.

BMR

Hope your tub works out !!!!

Link to post
Share on other sites

Glad to hear your Onzen problems are getting worked out. Ours has been working great. We just got back from a week in Maui and checked the sanitizer. System took good care of itself while we were gone. Have had no problems and no complaints.

On the other hand. I have been talking to a guy at my work who also bought a tub at fair time but it uses regular chemicals and he has been having nothing but problems. In fact, he told me the other day his was green and smelled bad. The wife and and I are extremely glad we went with the Onzen system.

Link to post
Share on other sites

we used our spa yesterday and we noticed a big difference in the quality of water, it had a soft texture to it, left the skin feeling soft and it felt good and for the first time i actually relaxed in it.

I just hope the install error (valves) havn't put any long term damage to the Onzen system as a whole.

Early days though, but if the last 48 hrs are anything to go by, things are on the up. B)

Link to post
Share on other sites
we used our spa yesterday and we noticed a big difference in the quality of water, it had a soft texture to it, left the skin feeling soft and it felt good and for the first time i actually relaxed in it.

I just hope the install error (valves) havn't put any long term damage to the Onzen system as a whole.

Early days though, but if the last 48 hrs are anything to go by, things are on the up. B)

My Problems are still present

Tech came and said thoroughly checked the system. Says everything works great and Onzen checks out. SO, I dumped the tub AGAIN as instructed, cleaned it thoroughly with bleach, cleaned that out, filled the tub, put in two full cups of bromine salt, one cap of ultra spa, set cp to 3, and fc to 1. I checked the ph and the alkalinity, both were in spec. The water looked great that night. It is now 24 hours later. Free bromine according to my strips is zero, water is starting to look cloudy again. No one has been in it or the tub touched in any way. I am getting so frustrated, I do not know what to do. I am bringing in the water for a test tomorow but am going to start proceedings toward getting the tub returned and then buying another tub.

Is it possible that the bromine salt in the bucket is actually not bromine Salt ?????? I am grasping at straws here.

BMR

Link to post
Share on other sites

BMR,

I am wondering if the bleach is causing it when mixed with other chemicals.

We were advised to use nothing when cleaning it out, a thourough rinse and wipe down.

As for the salt being the wrong type, anything is possible, my Onzen was installed incorrectly.

It is Natral Onzen Salt, Bromide Salt Blend that they have given you?

I am at a loss, i do have the business card of the tech that came to my home, if you want i can PM you

and i can give you his number and name and see if it was him for sure that came to your place.

Are you getting lots of bubbles coming from the Onzen output (in footwell) when turned on?

And when off, are you getting a large bubble every 6-10 seconds?

Link to post
Share on other sites
My Spa is fixed!!!!

Nigel

I'm glad to hear that your spa is working. On behalf of Arctic Spas, I apologize for your inconvenience. In a PM, I'm going to ask for your spa s/n, as our Quality Assurance team is going to want to look into this. I'll also forward your comments about the installation to the owner of the dealership. I'm sure they'll pay attention.

Link to post
Share on other sites

Hi guys,

Recently my (arctic fox with Onzen) tub has gone from not requiring much attention to getting very dirty, very quickly and the filters have been dying faster - I use those foam batting ones - the first lasted about five months no problem, the last two have died after about a month. I've emptied, scrubbed, dried and refilled. Green scaling appeared on the filter plastic, and on the sides as a slight "tidemark."

I opened the spa door to inspect the Onzen dial and found everything was fine - except for some slight pooling of water on the floor of the inside of the tub on the right hand side. The water is slight, but brown and rusty looking. Should I be concerned?

Also, can someone list what their setup from clean, fresh water is, with regards to chemicals? Do people add anything? Everything?

Link to post
Share on other sites
Hi guys,

Recently my (arctic fox with Onzen) tub has gone from not requiring much attention to getting very dirty, very quickly and the filters have been dying faster - I use those foam batting ones - the first lasted about five months no problem, the last two have died after about a month. I've emptied, scrubbed, dried and refilled. Green scaling appeared on the filter plastic, and on the sides as a slight "tidemark."

I opened the spa door to inspect the Onzen dial and found everything was fine - except for some slight pooling of water on the floor of the inside of the tub on the right hand side. The water is slight, but brown and rusty looking. Should I be concerned?

Also, can someone list what their setup from clean, fresh water is, with regards to chemicals? Do people add anything? Everything?

I too have had nothing but a headache with my Arctic Yukon with the Onzen system.

I purchased it in August and have had to change the water once a month (even though my wife and I only use it about 3 x a week). I have gone through 4 buckets of sodium bromide salt, countless bottles of Refresh and 4 complete water changes!!!!!!!

I am thoroughly disappointed with this product. I have a $12,000 tub in my back yard that goes green within a week after a water change. I have left messages with the service department and I'm still waiting to hear back about a service call.

The system is producing lots of bubbles as it should but zero sanatizer. My CP level is set to 3 and I only get an ORP reading of 150, no measureable amount of bromine is being produced.

Any suggestions Tom?

Link to post
Share on other sites
Hi guys,

Recently my (arctic fox with Onzen) tub has gone from not requiring much attention to getting very dirty, very quickly and the filters have been dying faster - I use those foam batting ones - the first lasted about five months no problem, the last two have died after about a month. I've emptied, scrubbed, dried and refilled. Green scaling appeared on the filter plastic, and on the sides as a slight "tidemark."

I opened the spa door to inspect the Onzen dial and found everything was fine - except for some slight pooling of water on the floor of the inside of the tub on the right hand side. The water is slight, but brown and rusty looking. Should I be concerned?

Also, can someone list what their setup from clean, fresh water is, with regards to chemicals? Do people add anything? Everything?

I too have had nothing but a headache with my Arctic Yukon with the Onzen system.

I purchased it in August and have had to change the water once a month (even though my wife and I only use it about 3 x a week). I have gone through 4 buckets of sodium bromide salt, countless bottles of Refresh and 4 complete water changes!!!!!!!

I am thoroughly disappointed with this product. I have a $12,000 tub in my back yard that goes green within a week after a water change. I have left messages with the service department and I'm still waiting to hear back about a service call.

The system is producing lots of bubbles as it should but zero sanatizer. My CP level is set to 3 and I only get an ORP reading of 150, no measureable amount of bromine is being produced.

Any suggestions Tom?

Looks to me like the Onzen system is bad. I bet it's not producing any ozone which is probably why you are not getting any sanatizer.

My Glacier Signature is working great since I b ought it this last July.

Just got back from spending 7 days in Mexico and the sanatizer levels was where it should be.

Have you been in contact with your dealer service department and what are they saying?

Chuck

Link to post
Share on other sites
I want to merge all the onzen threads for better time management - it will give us one single place to look. Any objections?

Hi Tom,

When will all the Onzen threads be up? Did you remove them?

Huh? They're still there. Found this morning:

Onzen Salt Blend, Where to Purchase

Onzen and Tub Maintenance Update

Verifying Onzen Settings

I hope to merge them so we all have only one place to read, but haven't had time yet.

Note to all: apparently the Onzen help line has been reassigned from R&D to Warranty and there are now waits for call returns. On behalf of the warranty guys and gals, my apologies. However, emails to the onzen help email (see your owner manual) are being answered promptly so please give that a try.

I have PM'd most of you with updated materials (I appreciate your reviews before I post them on the forum) and if you want a copy please email me directly tom at goarctic.com

Link to post
Share on other sites
we used our spa yesterday and we noticed a big difference in the quality of water, it had a soft texture to it, left the skin feeling soft and it felt good and for the first time i actually relaxed in it.

I just hope the install error (valves) havn't put any long term damage to the Onzen system as a whole.

Early days though, but if the last 48 hrs are anything to go by, things are on the up. B)

My Problems are still present

Tech came and said thoroughly checked the system. Says everything works great and Onzen checks out. SO, I dumped the tub AGAIN as instructed, cleaned it thoroughly with bleach, cleaned that out, filled the tub, put in two full cups of bromine salt, one cap of ultra spa, set cp to 3, and fc to 1. I checked the ph and the alkalinity, both were in spec. The water looked great that night. It is now 24 hours later. Free bromine according to my strips is zero, water is starting to look cloudy again. No one has been in it or the tub touched in any way. I am getting so frustrated, I do not know what to do. I am bringing in the water for a test tomorow but am going to start proceedings toward getting the tub returned and then buying another tub.

Is it possible that the bromine salt in the bucket is actually not bromine Salt ?????? I am grasping at straws here.

BMR

Did you get your Onzen problem sorted out? I'm having the exact same problem as you....NO BROMINE BEING PRODUCED. I've now filled the tub up again for the 4th time using the new proceedure of adding only 1 kg of salt (soduim bromide). All of the settings have been set as recommedned (CP 3, FD2, FF4)....It's been 3 days now and no measurable sanitizer!!!!

I don't know whats wrong. I've followed the Onzen troubleshooting guide and the system is bubbling as it should however no bromine is being produced. I'm wondering if the system will still bubble even if the electrodes are not functioning. What really annoys me is that the Arctic service department said that if the send a technician out and they can't find anything worong with it, they are going to stick me with a $100 bill. My tub is only 4 months old and this Onzen thing has never worked properly, as far as I'm concerned they should send a technician out free of charge for all of the hassel that I've experienced with this thing. I see that the tech told you that there was nothing wrong with your system which can't be the case since you're still having problems....Did they charge you for the call?

Link to post
Share on other sites

Anyone experiencing Onzen issues is urged to contact the Onzen help center at the email address in your owner manual (p. 6)

Link to post
Share on other sites
  • 2 weeks later...

I have sent a draft of a revised manual to many who posted in the Onzen threads but have received no feedback so far.

If you received a copy, please help me out by letting me know in what ways it is better than the earlier drafts and where it still needs improvement.

I will be offline from Dec. 20 to Jan 4, back Jan 5 and will not be moderating nor responding to posts or emails during that time.

Thanks and Merry Christmas.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...