Jump to content

Search the Community

Showing results for tags 'polygroup'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 1 result

  1. Hello, I’m pretty new to Pool stuff but was doing well until 1 or 2 weeks ago. Then algae arrived and I began researching. The first time I just shocked the pool. Talked to a pool place and they directed me to brush the pool and then shock (makes sense). So I brushed the pool and shocked it again. I made sure the filter cartridge was rinsed and had the pump running. It went away for a day or two. The cover doesn’t stay on completely and it stormed. Algae returned. So I brushed the pool and shocked again. Filter rinsed several times and pump ran. The next day it looked better so
×
×
  • Create New...