Jump to content

Search the Community

Showing results for tags 'jets'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

  1. We have a 2200 gallon Hot tub that when the Jets are turned on for the first time after the circulation pump has been turned off and back on for whatever reason, it makes the water Milky for a short time. It is fine after that first start. We dump the water once a week and all chemicals are typically in the ideal range. What could be the cause of this? This has been a fairly recent development. We had to replace some laterals in the filter and change the sand but the issue with the Jets was occurring before that. Appreciate any and all help.
  2. Kids pushed Jet switch on and off multiple times. No longer works. Pushing switch does illuminate the switch panel and display the jets graphic on and off. The rest of the buttons work as well (temp up/down). No signs of burnt wires or areas on the circuit board. The Jet Pump does work...ran power directly to test. Appears as though the both the switch and the pump are working as they should. Assuming something with the circuit board. 1999 Tiger River Bengal M. Any help would be GREATLY appreciated.
  3. Hello, I picked up a used LA Spas HEET model and I've just wired it in and fired it up. When you turn it on you are supposed to set the desired temp first thing. I am not able to set the temp up or down, but the spa is heating. I turned it on about 4pm yesterday and its heated up to 100 by 6am this morning. Also the jet 3 button doesn't seem to do anything. I'm not sure if I have a bad topside controller, or if there are other issues.
  4. After fixing my problem with broken suction covers, I now have many jets not working in my 2008 H2X swim spa. Leaf debris, I suspect. Any tips on how to fix this?
  5. I picked up a 2004 Hot Spring Envoy that has sat a few years. After getting it moved, wired up a new 50amp gfci spa disconnect, I filled the spa and everything started up fine, all the jets worked and heater was going. The next morning it was warming up good, one jet pump quit working(you could hear a relay click), after it got to Temp(104), both pumps would not work, now when you press either jet button or the clean button, it throws the breaker. Any help you be great, thanks
  6. I have a spa that overflows into my pool. I noticed the jets suddenly were not pushing out much water, then my blower was not working. I replaced the blower, the new blower kept overheating. We narrowed it down to having some sort of blockage. We had rotorooter try and clear the line (way overpriced) then we used a gas pump and pulled the water back from the spa, hoping to dislodge anything, there was a small piece of plastic that came out. Then we pumped through the jets in hopes to push anything out. STILL, the blower is overheating and the jets seem very weak without the blower.
  7. I have a 2004 or 2005 Caldera Aquatic Melodies Elation Spa. 1. I have several jets that have lost parts (the center is gone out of a Euro Pulse jet, some small ball bearings came out of a VersaSsage Jet, etc. I cannot figure out how to remove the jets to replace or repair them. The videos I have seen show them being twisted counter-clockwise past the adjustment stop-point, then pull out, but these jets are all counter-sunk into the tub walls and there is no way to get a good grip on them to turn them hard enough.... is there a tool that is specifically for this, or am I going to have to ri
  8. hi i have a 2005 t-300 softub. works great. the gaskets all need to be replaced on the jets. first question... do i have to buy the gaskets from a softub dealer? second question.... can i put in the newer jets in a 2005?
  9. How does one remove the Jet Face (#2 in diagram)???? Directions say… Remove the jet by grasping the jet faceplate and pulling it away from the spa shell. With jet in hand, two o-rings should be on the rear portion of the faceplate. If either o-ring is not present, inspect the inside of the front wallfitting and remove the missing o-ring. To reinstall the jet, reverse steps 1 to 3.Important: Make sure that the o-rings are properly seated. It rotates cw and ccw and comes to a dead stop, but it won't pull out. I tried prying it off with a plastic panel r
  10. I have a 2003 Prodigy whose jets just started turning on by themselves, but then shut off. Since heater does not run when jets are on on this model, temp drops. I have not observed whe/why this happens but note the green light not on and it’s clear jets were on. Switch panel short (condensation in the display)? Help!
  11. I bought a 199? tot tub, don't know the manufacturer. I had a broken air control valve, and replaced both. Some of the Waterway, screw in jets were not putting out air. I placed a shop vac, set to discharge, over the air control, and air did come out of all the jets attached to that manifold. I removed some of the jets to clean. They adjusted hard, but were not stuck ,or clogged, with no missing o-rings. I put them back into the housing, and no air. I removed the air line from the manifold, and still no air to the jet. Looking at one of the jets on the other manifold that was wo
  12. Hi all! New to this forum and to being a hot tub owner. We purchased a home that had a 2015 Hot Springs Flair left behind. Filled it up through the filter but the jets aren't working so I'm wondering if there is an air lock. When filling it up through the filter I didn't hold the hose in, I let it hold itself so I'm curious if I should've held it in while filling it to apply direct pressure. is there a bleeder valve on this model? The heater seems to be working and so do the LED lights. We are getting champagne bubbles and when trying to get the jets to work it kicks on like it's trying to.
  13. I have a Tiger River Spa, the Sumatran N model. Recently, the water went cold, and I could not get it to heat. After following threads and discussions in this site and others, I tested and was able to determine that the heater was bad. At that point, everything else in the spa worked, and no circuits had been tripped. Jets ran, control board worked, main circuit board green light and red light both lit. The failed heater was a Watkins No Fault 6000 with the following information on the sticker on the bottom of the unit: 240V6000W, THJ01, SET-DO-OH-CO, 11113, 240328, 36(8?)10 REV K. The
  14. Hi all, I'm new to hot tub ownership, so please bear with me. I'm living in the UK, and have recently been sold a hot tub by a family member; It's a Watkins Hot Spot RLX, and I believe is approx 12 years old (maybe older?). Was planning to buy one new in a couple of years, but we couldn't say no for the price we paid. It will certainly do for the time being. We transported the hot tub to my home, and located it in the back garden. Gave it a good clean up, and filled it ready for use. It warmed up nicely, and the pump is a little bit on the noisy side, but nothing we can't live with for now
  15. Hi everyone: I am doing research like I do on everything and think I have narrowed it down to 2 manufactures. Caldera & Marquis They both seem like higher end brands and I am trying to find what the real differences are performance wise quality of pump, jets, maintenance and insulation since I live in New England. One thing that stands out is the Marquis in made in the USA, but they seems more expensive? I work in the manufacturing industry and appreciate products made here. If there is anyone out there that has some pros and cons of the 2 brands it would be greatly appreciated. I will w
  16. I am new to this forum and I have been doing as much research as i can.(about 3 months) to research therapeutic hot tubs, it does not work so well. I go to the gym 5 days a week and know that a good tub will help by body repair. At this point I am leaning towards Caldera Makena. I definitely want a lounger but really want enough quality jets to hit my whole body. As more of you experienced ones out there know, more jets are not necessarily better. There are a lot of manufactures and styles out there is is very tough to choose. I am an engineer so i will research a lot. Any input is helpful!
  17. Please help. I have a spa crest hot tub. We have recently replaced the circ pump, and entire balboa box with circuit board and heating element etc. Circ pump is 24 hour continuous but kicks off when jets 1 is turned on causing dry and overheat error codes. The circ pump will continue to run simultaneously with jets 2. Im at the end of my troubleshooting skills. Any advice will be much appreciated!
  18. Hello. I've got an older CalSpa 2000 and it runs well during the summer, heating to 100+ degrees as needed, but the outdoor temps tended to be from 75-95 degrees. It appeared to heat well simply by having the cover on, but I noticed if I had the temp set to 100, it would drop to mid-90s even during the summer. The pump would run constantly and the heat light would never come on unless I turned the pump to high speed with the "jets" button and that only lasts about 15 minutes each time. So, I'd have to wait around and hit the jets button every so often to get it to (and keep it at) the desired
  19. I have a Royal Spa Royalty II and it uses air switches. Just recently, when I push in the button to turn my jets on they come on for a split second and then turn off. I cut power to the tub and took out the air switch and tested it. I can see the air switch clicking as I press the button and can't see any potential damage. Any ideas as to what what would cause this?
  20. I just finished building the body of exercise pool with a dimension of 8'x16'x52" and I am about to start the plumbing work. I have two 2hp regular pool pumps and want to know whether I can use one of them to driving jets to make a strong enough water current for exercise. If it is too weak, then what kind of special pump I need for this purpose and what specifications of this kind of pump I should know. Hoep someone can advise me on this technical issue. Another question I have is the jet I put on the pool is not adjustable. Is there other way to make the current adjustable? Thanks, Victor
  21. So the low speed jets that circulate the water and gets the water hot was working fine. Then I did test using the test trip to check chemical levels and it was high for ph so used spa down and got that to the ideal level also it was low on bromine it was a pink shade so just one less then the first ideal level so I thought I added the correct amount it said 4 teaspoons to every 200 gallon water and i think mine is 1200 gallons and I actually put in less then that maybe for like 600 gallons since it was close to the ideal level. I waited the 30 minutes I did a test again and it was at the high
  22. Hi everyone, long time no visit.... I've had two babies since I was last here... anyway, you were a great resource before I hope so again. I was doing the fall clean out of the tub, and while unscrewing the jets, I was shocked to find 100% failure of the small 3" jets .... a small plastic disk in the back of each one had either fallen out, or stuck in the jet. I"ll try to attch some photos. Any ideas? I was asked to switch over all my jets in 2008 to this new screw in kind.... I was shocked 100%? what are the chances?
  23. Hi All, I purchased a used 2003 Landmark S Hot Spring Spa. All is working well besides the moto massage jet. This seems to be the only jet not functioning in the tub. I just replaced all 5 filters and ensured that no clogs are present. I assume the jet is broken but know nothing about it... thus the post. What are your thoughts? What should i check? Am i able to repair this on my own? What type of costs am i looking at if replacing by myself or hiring professional? Looks like the best seat in the house but no jets Thank you
  24. I just picked up a used tiger spa that worked fine at the original owners house. I filled with water and tried the jets..it just surged ..... I let it surge for 5 mins looking for clogs in the filter and found nothing. then the jets finally pushed out water ...but then none of buttons would respond.. killed power for 1 min. then powered it on and the jets just surged again.. any ideas??
  25. Classic Model F Serial # F461386 Built in the last quarter of 1996 Dedicated 20amp to the pannel I had no power to the hot tub, replaced the G.F.C.I plug, drained, cleaned and refilled it. Next day it was warm, I added the chemicals and pushed the clean button and walked away. The clean button shuts off in about 10 mins automatic. Later on in the day I went back to look at the hot tub and there was what I thought to be black plastic peices in the water. (this was yesterday). Tonight I retrieved the peices by going in the hot tub. The water still warm and circulating. The buttons dont work
×
×
  • Create New...