Jump to content

Search the Community

Showing results for tags 'Spa'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

  1. Hi! Have an older model morgan spa bottom 3 blinking lights, light above temp 4th icon with 2 vertical curvy lines staying lit - nothing coming on. Just changed the bottom fuse in the heater. Thanks so much!
  2. Hey Guys and Gals, I'm really hoping someone here can help me as I'm at a total loss... I recently moved into a new rental home and there is a nice 2006 Spa Coleman Hot Tub outback. It looks brand new. The owner of the property indicated it wasn't working but he would spend up to 200 on parts if I did the work to which I agreed to see if we can get it going. So first off it hasn't ran in about a year. The water in the tub is stone cold maybe 40 some degrees. When you power on the breaker the tub goes through what appears to be a self check and flashes 100 then 21 then 114 then 240 and the
  3. Hello, Wondering if anyone can help me identify what this is. Recently had an FL2 error code on my spa and while inspecting the wires behind the panel I noticed some charring in an area towards the bottom of the control box. This was lying at the bottom of the box. The tub seems to work fine other than the FL2 error and I can’t find anywhere on the board where this would have come from.
  4. I have a 2001 Hot Springs Landmark that isn't getting heat and the jet motor isn't working. The circ pump is working great. I replaced my relay board and my main board a few months ago and it has run great since then until now. I'm pretty sure the relay board is supposed to have a red light and a green light but all I am getting is a red light. The red and green light on the main board are lit up as expected. No other lights inside are on. The power light on the controls is on but the ready light isn't, again, to be expected. I would assume this new board is bad but I'm not sure. Any guidance
  5. Hello, I have a Coleman SaluSpa that I’ve had for about 2 years now. I used it last year with no issues and then this year, I’ve had some issues with the water staying clean. I’ve attached some pictures and a video that show what’s going on. There is a lint like substance that floats around and when I try to scoop it up, it breaks up into tiny pieces. When I first remove the cover, it’s mostly collected itself in a couple big piles of whatever it is. I’ve replaced the filters, chlorine, PH, and shock has been applied consistently to ensure an uninhabitable environment For bacteria. S
  6. Hi there! We recently bought a house that came with a 14-year-old Tiger River Spa Bengal that appeared to be in excellent condition. It was set to 97 and the system panel showed "READY". And putting my hand in the water, the water did feel heated. I never had a hot tub before so I went to a local Hot Springs Spas dealer and they gave me a great run down of what I had to do. First step was draining and refilling. I shut down the power and drained it and removed the filter etc. I refilled the tub through the filter compartment. Once that was done, I put the filter back in and fired up the p
  7. So what now....? I got my Lay-Z Spa Hawaii Airjet at the weekend and set it up yesterday. Chemical readings seem to be ok. So the spa is heated up to 40oc. Do I now just leave it switched on or do I use the timer function thing (not that I have worked that out yet)? Complete novice no idea what I am doing. TIA
  8. Hello everyone! I'm a newbie here so please forgive my lack of knowledge. We recently got a hot tub and I'm wondering about a shock product that I keep seeing in a local retailer. It's called Clorox Pool&Spa Shock Xtra Blue 6-1. I am wondering if this is ok to use in a hot tub? The bottle says pool&spa, but since there are no direction for spa use.. I'm a tad confused. I looked up a material safety data sheet googled the main chemicals. It seems all the chemicals individually are found at similar percentages in other Spa Specific Products. I tried emailing Clorox and they never replied
  9. Just wondering if anyone else ownes an arctic spa baffin 45. I cant find any thing about them online anywhere. Just wanted to compare experiences with someone who owns the same tub to see if they have run into the same problems as me. Namely, the jets powered by pump 1 being very under powered. Pump 1 shutting down occasionally. And filter bypass valve breaking. Thanks, Josh.
  10. The bromine tablets I've loaded into the floating dispenser in my hot tub keep caking up together, forming a solid mass that is very difficult to break up and remove. What's the best way to clean out my floating dispenser and how can I keep this from happening again? Thanks!
  11. Hello all! I didn't get any responses on my last post so am trying again as I have now troubleshooted a bit further. I have a mid-2000s model Hot Springs Vanguard. Everything is working except I cannot get the heat to rise above 98 degrees, even when set to 104. Here is what has been tried thus far: New circulation pump New GFCI 20 amp breaker installed New heater - Note: I had to jump the pressure switch on the board because the new heater does not have the external cord that runs to the circ board Disconnected Ozonator from Circ board (Line was cut p
  12. Hi all. I just changed the water in my Tropic Seas spa (375 gallon, 6 seater) and when I turn the ozonator on, the water foams up. I am using a Nature2 spa stick and bromine along with Cense. I havent always had this foaming issue. I cleaned the spa after draining it. Filled it as I always have, test strips indicate everything in the recommended ranges. Any idea on this? Would love to be able to use the ozonator without this foam. I know some bubbles are expected because its air blowing through the water, but it foams up. Once the ozonator is off, it does disappear relatively quic
  13. Feel like I've read every thread possible but looking for a simple answer I can't seem to find anywhere!! I currently have this paver patio laid in my backyard and I wanted to know if I can place the hot tub on top of the pavers that are already laid. As you can see, the pavers are slightly uneven (its very slight, less than an inch with some in the middle being a little higher than where the outsides would like) and I know hot tubs are supposed to be level. My question is what is the best way to level the hot tub on this surface? Is there a need to buy Handi-Spa pads and will placing
  14. I have a spa that overflows into my pool. I noticed the jets suddenly were not pushing out much water, then my blower was not working. I replaced the blower, the new blower kept overheating. We narrowed it down to having some sort of blockage. We had rotorooter try and clear the line (way overpriced) then we used a gas pump and pulled the water back from the spa, hoping to dislodge anything, there was a small piece of plastic that came out. Then we pumped through the jets in hopes to push anything out. STILL, the blower is overheating and the jets seem very weak without the blower.
  15. I am looking for a new (external) heater to heat my hot tubs, currently using a "Coasts st-11" 11kW single phase heater, but I can't find a matching model sold in the UK. Can anyone provide me with a source for this (or suitable alternative) heater sold within the UK?
  16. I have a 2000 Sweetwater Palermo spa. The water temperature is 3 degrees lower than the digital readout on the display on my control panel. (the temperature from a thermometer of the water reads 97 degrees but the display reads 100). I have a new heater, new filter and recently changed the water. I've had this spa since 2000 and am very familiar with how it heats and this is really not normal for the spa. Any clues what the issue might be? Sensor, topside control panel, etc.? Thanks.
  17. My outdoor spa/hot tub started leaking two winters ago so I took it out-of-service, and had the local dealer out to look at it this Spring. They charged me $120 for a visit, spotted an obvious leak, then told me they no longer service spas. 8^( The good news is that apart from the obvious leak, and a few top-side parts that should be replaced (easy fixes), the controls, heater and pumps all seemed to work properly. Not bad for a tub that’s got to be 12-15 years old. So I gave up on it and tried to give it away this summer. No luck. Two potential takers both backed out afte
  18. Posting on here as I feeling I’m getting the run around. I won’t post the make as I’m trying to work things out with the company. Few weeks ago my hot tub hit 107 , was set for 100. I was told it’s because it’s hot out. Bought this unit 3 months ago for a pretty penny. Upstate ny temps in mid 80s . Also one seat it’s jets stop working due to design flow. It’s been an issue since day one but besides the point. I powered it down and left it off for a day 85 degree day checked the temp through out the day. Went down 1 degree. It’s now set to 98, last night at 11pm was 101, got in after 20 minutes
  19. Hi all, first time poster. So I had a hot tub growing up, but never really took part in the maintenance being a kid (although drainage and scrubbing was all on me 👌). That led to me wanting one again as an adult. I don't have a lot of room and I rent, so I found an mspa b141 "4 person" hot tub. (quotes because I can't even figure out how 4 people can actually fit it in! Not just space wise, the water almost overflows with 3!). That is an inflatable Hot tub for those wondering. So like most people, learning how to deal with balancing and water chemistry isn't instant, but through research
  20. Hi, we are looking for our first hot tub and I’m hoping you can help with some advise. We live in the Twin Cities, so efficiency during the winter extremes is very important for us. I’m not overly concerned with number of jets, stereos, lights, etc. What I am concerned with is insulation, reliability (in the hot tub and the dealer), and TCO. I’m curious to hear from others on here what their buying experience was and how they feel their hot tub did getting through this last brutal winter. I’d also love to hear opinions on purification systems (salt, chemical, ozone, etc). We are looking t
  21. I'm hoping I can get some help Its my job to take care of a brand new 2018 Hotspring Sovereign for a friend. Its was installed about 6 weeks ago and only used 3 times by my friend. Here is the problem the logo light will flash red after 3 to 4 hours. The hot top dealer had me clean the filters there's 3 , that didn't work after a few hours it started blinking red, then they had me take the filters out all together and run the tub still after a few hours the light is red and every time it goes red i have to reset the main breaker. They have had there service team out 3 times to correc
  22. I have a Balboa EL2001 Mach 2 circuit board and ML700 topside panel with aux top panel. I am trying to pinpoint if I have an issue with the topside panel or the circuit board. The board was replaces under 2 years ago. The top panel acts like everything works, icons change like it is working, but nothing actually turns on. None of the 3 motors and not even the spa water light. All the fuses are good and I don't see any visible damage on the board. I would love to be able to unplug both top panels and test if I can get the circuit board to turn anything on. Is that possible?
  23. Hey guys, looking for some technical support. I'm retrofitting a new S-class Gecko spa pack to my 2001 Gulf Coast spa. Once installed, the display screen backlight turns on, but the display does not show anything. Further, the buttons on the panel do not control the indicated items. For example, hitting a button such as the light button turns the blower motor on. Hitting the arrow down button turns pump 1 on. None of the functions are correct. So, I tried a brand new panel, same issue. I have tried changing the jumper position with no change. The display continues to not work. So, I tried
  24. Has anyone heard of Natural Whirlpool Spas & Baths. I've got a spa that has model # NS5001 and its fiberglass
  25. Greetings. I have Sundance Majesta that needs a replacement pump. The rubber mounts have torn and need replaced. They are just like these, which I've purchased 4 replacements as well. The threaded metal "bolt" isn't one piece. There is a top and bottom "bolt" with the thick rubber bushing between them. But, I can't seem to get the 4 old "stems" out of the wood floor (the rubber bushing and top bolt have broken off and been removed). Any suggestions on how to remove these old stems? Can't get enough "bite" from channel locks. I assume they just unscrew from another threaded metal piece pr
×
×
  • Create New...