Jump to content

Search the Community

Showing results for tags 'replacement'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 5 results

  1. Hi All, Question on running multiple pumps from a single board connection. As background, the Thermospa spa I inherited has 5 jet pumps, a circ pump, a blower, a light and a diverter valve for a wave lounge. I had no idea how 'over-featured' this tub was, but it's all mine now and I'm working through a series of issues slowly (with much help from the guys on here). On my existing board (Balboa EL8000 Mach 3), pumps 2 & 4, and pumps 3 & 5 connect to the same connector on the board with a 'Y' or splitter connector. Then the 'hot' pin on one of the split connections is jum
  2. Can anyone help me with a replacement for this capacitor? I think the specs say: 130 - 154 micro farads 60Hz But I can't see what the volts AC says. There are no other markings on the unit. Any help would be great. Thanks, Rob
  3. I have a 2009 J-480 with the old CD player/AM/FM and Ipod connection system. It's 2020 and I would like to replace it with something hot tub certified and bluetooth. I preferably like to find something with the same footprint as the unit I would replace. Any suggestions or aftermarket ideas? Thank you so much.
  4. I was gifted a 4 person ez-spa by Dream Maker, it is a little bit older and has been sitting for a couple of years without running. We cleaned it up really nice and plugged it in for a test drive and it kept tripping the breaker. After watching a few videos on you tube, and by the looks of it, I believe I need a new pump. My question is, does this type of spa require a heating element/sensor or does it require a heating pump? This is what everything looks like. It appears to me that there is not an additional heating element, just the pump, but when I look at the control panel, the
  5. Hello, After moving our Hot Springs Sovereing (2003), the light does no longer function. I can see the icon on the display lighting up, but no light in the pool. I guess the first step is to replace the bulb. - What's the spare part for this? - Can this be done via the service panel, in a fairly simple manner? Thanks!
×
×
  • Create New...