Jump to content

Search the Community

Showing results for tags 'leak'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

  1. I have layz Vegas and today it is flat as a pancake. When I try to reinflate the air comes out of the bubble skirt and the hot tub won’t inflate. is it dead ?
  2. I have a leak on the waterfall side of a tiger river spa bengal model MM. Does anyone have a diagram of the plumbing lines(no foam) or any electrical lines that might run through that side of the spa? Not sure where to start digging through the foam. And i don’t want to dig more than i have to.
  3. For the past year or so, my 1999 Hot Springs Prodigy has been leaking. At worst, it drops an inch or more per week. An application of FixALeak stops the leakage for a couple of weeks, then it starts up again slowly. My dealer couldn't find a leak, although he did recommend I change in spa light fixture and gasket in case that was the problem. Did it, but it made no difference. There is no obvious water in the motor compartment. In the heat of summer, I don't normally use the spa. I just turn it down as far as it goes - 80°. That keeps the circulating pump going for filtering. I'd like to just disable the heater completely, but I can't see how to do that. This summer I thought of a way to get some benefit from the spa. I just drained it (regular maintenance) and filled it with cold water. Great for soaking. I flip the breaker to keep it from going back up to 80°. Then twice a week, I turn it for one 15-minute clean cycle, adding chlorine each time. So here's the oddity where "part-time" comes into my subject line. Since I've been doing this, there doesn't seem to be any leakage. I have not put in any more fixaleak in quite a while. Given these facts, any idea what could cause a leak only when the tub is turned on, even without running the jets more than for two clean cycles per week?
  4. Hi there - I have a SaluSpa Miami (inflatable) and just brought it out for the season. Once filled up I started heating it up and came back the next day and noticed the water level had gone down significantly. After some investigation and trial and error I determined that it was related to the drain plug (I don't want to call it a valve) that sits at the bottom of the tub. I had never experienced this issue before. The leak was substantial such that it would render it effectively useless unless remedied (i.e. the water level goes down too quickly) The drain plug can be opened to let water out. To close it (seal it) you simply close it and push it shut. See pictures attached. This is much like the plug and stopper you use on inflatable pool toys. However, mine is not sealing and clearly is causing a leak. After some messing around with it (with O-rings) I think I actually "stretched" the rim of the drain plug area and it won't even stay shut now (which isn't that big of a deal since it was a bad leak anyway when it would shut). Has anyone else experienced this and any suggestions? The reality is I don't even need to use that drain plug for its intended purposes. I sub-pump or siphon water hour anyways. I was thinking of just getting some heavy grade waterproof tape or something to just cover up the hole but not sure that will do the trick. Again, I don't need to use the valve so I would be better off to just permanently "seal" off the area. Bestway's website isn't very helpful and all the reviews I read saying trying to reach out to them for input would be futile. Thanks for any help / suggestions!
  5. I am stumped. I have water leaking at the top of my hot tub frame and I cannot figure out where it would be coming from. There are no hoses in this area and the wet frame is above the water level of the tub. In the last photo you can see a black spot on the top piece of the frame then the water runs down the cross brace and soaks that end of the brace. There doesn’t appear to be any wetness at the top on the other three sides of the tub. Anyone seen anything like this before?
  6. Hi I am seeking help repairing an old hot tub in Wylie TX and having trouble finding anyone. Pump works, but leaks(may need replacing). Older heater leaking at the output end(may need replacing). Brad
  7. Hi I’m new to this forum but hopeful of some sound advice if possible please. I have a 2002 HotSpring Sovereign that has developed a leak. I’ve spent some time investigating it myself as far as I can and have discovered that: The leak is coming from behind the back wall of the equipment bay and making its way into the bay from around the large black (vent?) pipe close below it. I've attached a photo to clarify. This is the area where the Heater OUT pipe goes through the back wall, just to the left of where the Ozone generator is located. With just the Circ pump running, I could actually hear it dripping at one point. The leak seems to be dependant on whether I have the Jets on/off and also the position of the Jet control diverter. For what its worth, I have seen no leak in the 9 o’clock position but heavy leaking when turned to 12 o’clock. Though it was leaking steadily, turning the jets on in the 9 o’clock position seems to have stopped it! Currently, with jets off, it is now not leaking, but I’m pretty certain I can start it up again by turning the jet diverter control. I have a broken Air Check valve. It’s the Watkins 70289 part which looks difficult to get hold of in the UK. The valve has just snapped off so the pipe is currently open, albeit tucked up above the control panel. Early on, when the leaked water level stopped below the last jet, I suspected the multi-jet pack in the front right corner and had a dig into the foam to see what I could find. I was pulling out wet foam from fairly high in the wall but found nothing substantial and later decided it wasn’t the main issue, since the area has now dried out anyway. I have applied the Fix-a-leak product which may well have resolved some minor issues but I doubt will resolve this. Circulation pump has just been replaced. Heater was replaced previously. There appears to be no leak from any of the plumbing around these devices. I’m guessing I’ve got some kind of pressure related problem where the Jet diverter position relates to how large the leak is. Maybe this is entirely due to the broken air check valve or maybe its just a leak in the pipework that feeds certain jets. As I say, I’m hopeful that this information might solicit some useful replies please. Worse case it looks like I could retain a hot ‘bath’ with limited/no jets but equally I accept that it just may need to be retired if it takes too much effort to fix. Also, if anyone knows a UK supplier of the 70289 or an equivalent alternative replacement part, that would be great to know. Many thanks, any/all advice is much appreciated.
  8. I’ve got a 2004 Hot Springs Jetsetter that has been relatively trouble free until recently. Last month, a few days after water changeout, the level had dropped about 9 inches and I saw water leaking from below the spa in the back right corner in the vicinity of the motomassage. There was no water in the equipment compartment, so I scheduled a visit from a Hot Springs tech thinking it might be a quick diagnostic/ fix. No such luck. He came out, told me I had a leak and would have to drain the spa, move it away from the house, refill it, reheat it, and have him return. I drained, moved, and refilled the spa. I didn’t replug it since I was heading out of town for a week. When I returned, I replugged it, but did not check the water level. I’m thinking this may have been my first critical mistake. Or not. Did low water cause what happened next? The next day I glanced out to see if the spa had gotten to temp. There were no lights on the Control Panel. I checked the GFCI and it had tripped and would not reset. Checked the breaker in the house and it had tripped. Reset that and then reset the GFCI. The light on the GFCI glowed red so I assumed all was well. But there was no power getting to the spa from the 125v cord, so assumed the GFCI was toast. I replaced the GFCI, tested and confirmed it worked properly. There now is power getting to the main bus on the heater board in the equipment bay, but still no display on the Control Panel. No power from the main bus to the main board either. So I assume that the heater board & possibly Control Panel are toast. But I still have the leak to trace. I’ve pulled off most of the back boards and a few of the side boards. Found some soggy foam and kept digging but all led to dry foam. I can see water pooling in the back corner, but have not yet been able to follow it to the source. Tomorrow I will add some food coloring and be back to digging. The water is still leaking, however the level is dropping verrrrry slowly now- maybe 1 inch over the past 10 days. I’m assuming that’s because the circ pump is no longer working. But maybe not. If the food coloring doesn;t help to find the source, I'll likely drain and try to raise the tub so I can attack it from underneath. My plan is to keep trying to find the leak(s) and get that repaired first. Assuming that’s successful, the next steps are a bit of a mystery. So here are my questions: 1. Any hints on how to better track down a leak or is it just tedious trial and error? 2. Is there a logical way to test the Heater & Main Boards to confirm either is fried or not? 3. Is there a way to test the Control panel to determine if it needs to be replaced? 4. Are there things to check prior to replacing either Board &/ or Panel to ensure they don’t self-destruct again? i.e. what might have caused one or both to fry? 5. Can I bypass the board and energize the circulation pump to get some pressure into the system to help track down the leak(s) 6. Is there a better way to try to salvage this tub than what has been outlined above? It's been a great tub and I'd replace it with the same if we weren't planning to move in the next 2-3 years. Anyone want to weigh in with some suggestions and tell me I'm wasting my time?
  9. I have a Leisure Bay G2 spa, and I've noticed some water leaking from the base when I power on the pumps. It comes from a specific spot so today I opened it up and here is what I found (see annotated pic and video). While the 2-speed motor is running, I can see a drip-leak coming from the pvc junction above the wet-end. Additionally, there is a drip-leak from the wet-end itself, but I think this is likely from drip above flowing down the wet-end and dripping underneath it. I replaced this pulp in early 2018 and the new wet-end came with it so I'd be surprised if the wet-end itself was leaking, but what do you think? I added an image annotated with where the leaks I observed came from. How do I fix this? Just tighten the PVC? Could the joint be too tight? As I remember it I used a strap wrench to do it last time? Are there O-rings or anything inside of here? Should I replace the union? What kind of parts would I buy? VID_20200425_144451.mp4
  10. Hi! I was wondering if someone could help me. My hot tub is 6 months old. I am having a few problems with it. It won’t heat up and when I have checked the manufacture instruction it says the filter may need to be replaced and will show an error message. However, the filter isn’t too bad and the error message is ‘SH’ or ‘5H’, which isn’t the error message for a filter replacement. I have also noticed that when I take off the cap to the air valve used to inflate the hot tub there is water pouring out of it. I have emptied the hot tub completely to see if there are any noticeable problems and I can’t find any. I was just wondering if anyone could give me advice on what to do The hot tub isn’t a popular brand and I bought it from Studio. The brand is called Aqua Spa and the hot tub is an Aqua Spa Deluxe. thank you!
  11. I have a very old (20+) years Garden Leisure spa. It's circular and only seats four people at the most. I recently replaced the GFCI plug receptacle successfully, but upon filing, there is a small leak from the pipe connection just before the valve. The water drips off the bottom of the valve, but is in fact coming from the pipe connection to it. See photos. I'm not sure what valve this is, as we no longer have the manual and information online is impossible to find, but it appears to be a gate valve. There's only one pump. Is there an easy way to patch this leak without replacing the valve? If I do have to replace the valve, can it be replaced with only PVC pipe and forget about the valve? Thanks for your help. IMG_1037.HEIC IMG_1041.HEIC IMG_1042.HEIC
  12. Hello, I recently purchased a Dream maker Cabana suite 3500L. At first I loved it, but now 4 months in I am having a couple of issues. First, the jets and waterfall seem to be pulsating and you can hear the pump pulsating. I thought maybe a dirty filter or something was the problem, I ended up draining the whole tub, cleaning it, and refilling it. Problem came back. Second issue is, I have noticed that I am losing an inch of water in less than a week with very light use of 1 person. Something seems very odd to me for this tub being only a few months old; hoping for some thoughts. Thank you.
  13. My hot tub heater is leaking on one side of it on both pipes. What would anyone suggest to seal it or fix it. Do I need a new heater?
  14. I have the above hot tub and it's leaking quite badly. We've had the heater replaced and the pump is slightly leaking but not enough to explain the loss of water. We have Tri-X filters and I'm wondering: if the screw top which fixes them in place is not screwed in at all, would this would explain the leak or if the filters are damaged in any way whether the water would leak out I look forward to any thoughts. Best wishes
  15. Hi, I have a 2001 Hot Springs Vanguard. Over the last couple of years I have managed to find and fix a couple of leaks. Now it has another very big/fast leak. I initially guessed that it was likely the infamous bleed nipple. But the leak appears to stop with a fair amount of water still in the moto massage "buckets." The leak appears to stop with the water below the lowest hydromassage jet on the right side. (See video link below.) I know this doesn't necessarily mean anything, but the water also appears to come out from under the hot tub most heavily under that spot. But I dug out the foam to the back of that fitting and it doesn't seem to be leaking there. Although that area is such a tangle of pipes it's hard to get the fitting fully exposed. The foam is very hard around there. (See image) Any ideas for common culprits? Thank you! Video: https://www.youtube.com/watch?v=GxjZi0kkFlE
  16. My outdoor spa/hot tub started leaking two winters ago so I took it out-of-service, and had the local dealer out to look at it this Spring. They charged me $120 for a visit, spotted an obvious leak, then told me they no longer service spas. 8^( The good news is that apart from the obvious leak, and a few top-side parts that should be replaced (easy fixes), the controls, heater and pumps all seemed to work properly. Not bad for a tub that’s got to be 12-15 years old. So I gave up on it and tried to give it away this summer. No luck. Two potential takers both backed out after realizing what it takes to move one of these. Now I’ve got it blocked up, cleaned up a bit, and am determined to at least take a shot at repairing the leak. I got under the tub tonight and found the obvious problem… and I’m not happy. There is a PVC cap at the end of a manifold fitting and the cap hangs lower than any drain on the unit. Duh, I wonder why it cracked? Really poor design IMO. I was prepared to replace or patch a section of pipe, but this thing has me scratching my head. Not sure if these photos will help, but I think you can clearly see the crack looking from below in the first photo…I didn’t even have to scrape away any insulation. The problem here is that in order to try and get the cap as high as possible, the manufacturer jammed it on tight against the manifold stubs, one of which is not even used. Got any advice for repairing or replacing that cap? If I cut it off there’s no manifold left to slip a replacement cap on. So my thinking is to either: A) clean the surface of the cap and place and glue a new, larger diameter cap (if there is such a thing) over it, or drill a hole in the end of the cap and/or force the crack to open up so I can (hopefully) remove the entire cap. If I can do that, do I have any hope of cleaning up the old joint so that I might be able to install and seal a new cap? Thanks for any wisdom you can share.
  17. I had a leak in the AquaFlo XP2 pump in my Morgan Oceanside Spa. The leak was between motor and the wet end. I ordered a seal kit from amazon and received it yesterday. I closed the slice valves and started to remove the pump, but a significant amount of water started draining and did not stop promptly, like the valves didn't close. So I drained the tub, removed motor and wet end, and separated the two. I found a great video on youtube from Spa Superman describing this process. The motor and pump are relatively new; only 2-3 years old, so everything came apart easily. The impeller was a little hard, but not too bad. I replaced the o-rings and shaft seals, no problem. I reinstalled everything back into the tub, filled it up, and powered it on. I didn't break anything during this process. All the plastic parts are intact. The whole process went very smoothly. The pump ran for 2-3 minutes, then I got a bright orange spark inside the motor. It tripped the breaker. There was no whine from the motor, and the pump was running in low speed. I flipped the breaker back on, and tried to start the motor, but all I get is a "click" sound when I press the pump button. I think the click is coming from the panel. Any ideas what went wrong? I am suspicious of one of the valves. When I opened it, the handle came off in my hand, and some water shot out in a stream. Could that be stuck closed, which would have constricted output from the pump? Like I said, there was no unusual or scary sound from the motor, and the pump was running in low speed. I see no obvious sign of anything being fried on the board, and the two buss fuses look fine.
  18. I have a 2007 Hot Springs Vanguard spa that has a slow leak in the back right hand corner of the spa. I suspect it's in the Moto-Massage jet because it stops leaking when the water level gets just below that point. My question is, can the outside panels be removed in order to repair it. There are no screws and I don't see any staples even though I have read that they are held in place with staples. Do the panels just pry off? Thank you for any assistance you can provide.
  19. Hello, I have a Tiger River Caspian (2005), 230 volt, 50 amp. It developed a slow leak (5-7 days) that would drop the water level to about the bottom of the filter compartment intake. It was hard to identify the leak from the equipment compartment so we had a guy out who replaced all the check valves. Leak continued, so he replaced the Ozonator and the Heater. The leak was solved temporarily but from that time forward the heater GFCI would trip pretty often, which he just said to live with (I notice this seems to happen every time I top off the spa now). Within the year, the leak came back and again it stops at the exact same spot (top of filter intake compartment, which is also bottom of upper bench and at bottom of first jet counterclockwise from filter). I'm perplexed - would like to give this a shot myself, as it doesn't seem like a new jet leak given it's duplicate of before, but I don't want all my spas guts replaced by this dude for another $1500 only to have the ongoing GFCI trip as well, potentially, returning leak. On inspection, I do not see any leaking water around the heater. Does this sound like a check valve somewhere? Any thoughts more than welcome! Thanks.
  20. I have a 2004 Tiger River Bengal. My Smart Jet Diverter Valve was leaking from top and I had water dripping from large white pipes under tub shell behind control panel. I replaced diverter valve and o-rings. Works great. Problem now is that water is still dripping from large white pipes under tub shell when the diverter valve is in 9 o'clock and 12 o'clock positions and pump is running. Tub does not leak unless pumps are running. The water drips down from pipes in pump compartment as well as drips out of right corner of exterior casing(tub is on concrete slab with slight pitch to right). The large white pipes coming from manifold seem very durable. Could they develop a leak? Any ideas appreciated.
  21. Hi, i have a cracked valve that I need to repair (photo). Is there a way to separate these joints to get the valve out? Thanks, George
  22. Hello, when I bought my house 6months ago, it came with a Hot Springs Highlife portable spa which seemed to have not been used in ages. However, we were able to clean it to hygienic standards on the outside, then filled it up and to our surprise, the jets are working and the heater is working also. So, very happy and very surprised. We did a tube clean treatment for 24 hours, let it drain, and filled it up again. All looks good except that there is a leak in the pipe that pumps the water away from the pump. You can see that it already has been repaired in the past and the leak is only active when the jets are on but it's still a significant leak. The leak is on the top edge of the white part in the picture. That's where the water flows out when the pump is on and the pump is on the bottom of the picture, connected to the tube I'm wondering how to go about repairing this, or if it's actually possible. The leaking part is accessible, but the pipe goes to a tee and it's pretty much hidden away behind the panel. I attached some pictures. I hope someone can advise me on how to repair this leak. Thank you!
  23. I have the same Problem going on in the same spa, Who can help me? It has been 2 years since Mike left his reply... It's a Tiger River "Bengal" series and it leaking from the Right front corner "Right of control panel" of the spa from the bottom right corner and coming from a screen. I looked in the front panel and everything is dry as well as the right side panel. I also took off the corner trim and dry in there. I used a mirror to look under the corner and water appears to be coming from a little white tube about 1/2 inch in diameter from under the screen.. this model id from around 2004ish
  24. I have the same Problem going on in the same spa, Who can help me? It has been 2 years since Mike left his reply... It's a Tiger River "Bengal" series and it leaking from the Right front corner "Right of control panel" of the spa from the bottom right corner and coming from a screen. I looked in the front panel and everything is dry as well as the right side panel. I also took off the corner trim and dry in there. I used a mirror to look under the corner and water appears to be coming from a little white tube about 1/2 inch in diameter from under the screen.. this model id from around 2004ish
  25. Okay guys, I seek your expertise! I just bought this master spa 66t9 the other day. It has been sitting for over a year. Some of the jets seem clogged but all functional. I want it to be as close to perfect as possible. Under the control panel there is this hose that appears it broke off from somewhere but I cant seem to find where it is suppose to be hooked. It doesnt leak water or anything since it is the same hose that is wrapped up and ziptied, and covered in the foam in the left side of the picture! Any ideas to where this tube should go or connect to? Please help me! lol. I'm a spa newbie, trying to learn more to not only service our own but help others as well.
×
×
  • Create New...