Jump to content

Search the Community

Showing results for tags 'jets'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

  1. I just picked up a used tiger spa that worked fine at the original owners house. I filled with water and tried the jets..it just surged ..... I let it surge for 5 mins looking for clogs in the filter and found nothing. then the jets finally pushed out water ...but then none of buttons would respond.. killed power for 1 min. then powered it on and the jets just surged again.. any ideas??
  2. Classic Model F Serial # F461386 Built in the last quarter of 1996 Dedicated 20amp to the pannel I had no power to the hot tub, replaced the G.F.C.I plug, drained, cleaned and refilled it. Next day it was warm, I added the chemicals and pushed the clean button and walked away. The clean button shuts off in about 10 mins automatic. Later on in the day I went back to look at the hot tub and there was what I thought to be black plastic peices in the water. (this was yesterday). Tonight I retrieved the peices by going in the hot tub. The water still warm and circulating. The buttons dont work
  3. Hey guys, I finally got my Vita Spa Vintage LH hooked up and filled up but have a few problems. First no heat, no heat indicator lights and the high limit switch isnt tripped (checked to see if the lil red button had popped) Secondly, when i flipped the breaker the bubbler kicked in automatically, but the pump for the jets wasnt running. It only runs when I hit the Jet button on the control panel, and the jets arent working. Tried the 3 valves but no luck. My control panel has the old style temp dial with a button for jets,blower,and light. They all have indicator lights at the top. Any ideas?
  4. We bought a house with a 19' 30-year-old Rio swim spa (Rio Plastics , http://www.rioplastics.com). I'm doing a 1-time makeover to get in in shape for years to come. The spa is half in-ground, so I have access to most of the plumbing. I'd like to ask about jets. In the 350-gallon spa part, there are 5 jets up top, and one in the footwell across from the suction. These were driven by a pump with a 1-hp motor through 2" rigid PVC lines. One side was strong, but the last jet on the far side was pretty weak. The only air insertion was based on opening an inlet on the control panel on the spa side
×
×
  • Create New...