Jump to content

Search the Community

Showing results for tags 'hot spring'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 18 results

  1. Hello! I'm looking at a 2018 Pulse and a 2018 Grandee. The Pulse is $8,995 and the Grandee is $11,895. I'm looking for opinions on both models and if the prices are fair. Both include stairs, cover and lifts. What do you love about the Pulse or Grandee? We're pretty torn at the moment so any insight would be helpful. Thank you!
  2. I have a 2001 Hot Springs Landmark that isn't getting heat and the jet motor isn't working. The circ pump is working great. I replaced my relay board and my main board a few months ago and it has run great since then until now. I'm pretty sure the relay board is supposed to have a red light and a green light but all I am getting is a red light. The red and green light on the main board are lit up as expected. No other lights inside are on. The power light on the controls is on but the ready light isn't, again, to be expected. I would assume this new board is bad but I'm not sure. Any guidance
  3. I picked up a 2004 Hot Spring Envoy that has sat a few years. After getting it moved, wired up a new 50amp gfci spa disconnect, I filled the spa and everything started up fine, all the jets worked and heater was going. The next morning it was warming up good, one jet pump quit working(you could hear a relay click), after it got to Temp(104), both pumps would not work, now when you press either jet button or the clean button, it throws the breaker. Any help you be great, thanks
  4. I have a second hand hot tub that I received as a gift and we got it running a couple months ago. We have had some issues lately. It was running fine for about a month until the control panel began showing only a blinking “ready” and blinking “power.” The jets and light work fine but the temperature began to drop and after some research I assumed it must be the temp sensor. My boyfriend replaced that for me yesterday and at the time the water was warm, but not hot. After 24 hours it is starting to drop in temperature and isn’t nearly as warm. Now the screen is just blinking “ready.” I tried tu
  5. I am on my 3rd main board for my Prodigy Hot Tub, it happens every time we unplug the hot tub to drain, clean and refill. As soon as we plug the hot tub back in we get the Green and Red lights blinking and she doesn't heat up but still circulates. Yesterday is the third time, the power went out from a storm and when she kicked back in the lights were blinking on the hot tub again. I unplugged it for a few minutes and plugged her back in and still blinking lights. We enjoy it between refills but not enjoying the expense of these boards. Any ideas on whats causing this?
  6. We bought a house in South Dakota that had this Bengal Hot Tub. It worked fine for 5 years. Last year we spent the winter in warmer latitudes so we decided to leave it empty. Drained it and used a shop vac to suck out any remaining water. Filled it back up in May and noticed that it was leaking. Tried using that spa stop-leak stuff - didn't work. Using a car screw-jack, jack stands and a few blocks of wood, I stood it up on its' side. Found an old repair site and dug through the foam. Couldn't find a crack so I made a couple of repairs where I found hardened stop-leak. Th
  7. I have a Hot Springs spa - we had too many people in it over the weekend, and the water level dropped a lot. We filled it up by putting the hose in the water and now there is a blinking red light and the jets won’t work. Any ideas on how to fix it? Is it something i can do myself? Will leaving it for a day fix it? Thanks in advance
  8. I have a 2003 Hot Spring Grandee. I refilled it about a month ago, ran fine, all lights solid. Went on vacation for a week, come back and have no lights on and the 20 amp breaker immediately trips if I try to turn it back on. The 30 amp breaker is fine. I think this is for the heater, but even with just the 30 amp on, it's not heating and no lights light on the tub. Any suggestions for a fix. I called a technician but they won't be out until Nov. 22nd, and at this point, in Detroit, temps are going down into the 20's the next couple of nights. How fast do hot tub lines fre
  9. Need help being new to this. I have looked round a few shops now and have come to a split decision between the artisian south sea spa 748ldx and the hot spring hot spot relay. Both are the same price just need a bit of help? Thanks
  10. OK, please read carefully because the obvious response to this question cannot be right: My 10-year-old Tiger River Bengal spa has begun gurgling loudly. I hear the gurgles as bubbles traveling through the tubing. They can be heard all over the tub; there's no clear location for them. Bubbles coming from the ozonator are large. When I block the venturi with my finger, the gurgling stops in a few seconds. This means that air is NOT entering the system from somewhere else in the tub. So you would think the problem must lie with the ozonator, the check valve, or the flow restrictor - but re
  11. Hi all! New to this forum and to being a hot tub owner. We purchased a home that had a 2015 Hot Springs Flair left behind. Filled it up through the filter but the jets aren't working so I'm wondering if there is an air lock. When filling it up through the filter I didn't hold the hose in, I let it hold itself so I'm curious if I should've held it in while filling it to apply direct pressure. is there a bleeder valve on this model? The heater seems to be working and so do the LED lights. We are getting champagne bubbles and when trying to get the jets to work it kicks on like it's trying to.
  12. New to this forum. I have a 2013 Hot Spring Limelight series hot tub which I have had zero issues with until recently. I noticed the display letters/numbers started flickering and going off and on intermittently. Luckily, I was able to turn off the pumps and lights before the control head totally died! I removed the panel from the tub body and disassembled it, only to find that the silicon pad (3 buttons) on the left side which controls the jets and "mode up" and "mode down" settings was cracked around the base, allowing water to penetrate into the head and drip right onto the circuit board.
  13. does anyone have a plumbing diagram. I have a bottom leak that is about 1.5 - 2 ' in from the front of the unit in the middle. THe unit drains but not 100%, the well int he middle is still full.I am not yet able to get it out and turn on side, just atrating out there to see if anyone has the diagram and hs had similar issue
  14. does anyone have a plumbing diagram. I have a bottom leak that is about 1.5 - 2 ' in from the front of the unit in the middle. THe unit drains but not 100%, the well int he middle is still full.I am not yet able to get it out and turn on side, just atrating out there to see if anyone has the diagram and hs had similar issue
  15. Hello everyone! Seems like this is the spa place to be. I just recently got a beautiful Landmark S for free. Happened to be in my own neighborhood. The thing is immaculate, but does have a small leak in one of the upper jets. So I got it for free, built a deck to put it on and began to run electric. Got it all the way out to the tub and THEN found out it needs a special subpanel. The original owner doesnt want me to have his because "it will leave screw holes in the deck". Watkins wants $500 for one. So off to eBay I guess unless one of you have a better suggestion. From everyth
  16. Hello Everyone, I have been reading around the forums and learning a lot but still have some trouble. I am looking into getting a open style tub with no lounge. I like the idea of a 7ft or larger tub that is at least 36 inch deep. I am 6'4 and need the extra space. The other people that will be getting in the tub are also tall. I am running into problems trying to figure out what model to pick, the cleaning of the water and getting the most bang for my buck. The two places I have here locally are Hot Spring and Jacuzzi. Both look great but I am not sure what one to go with and what is better
  17. My education in spa plumbing continues! Thanks to the help I received on this board I have spliced in a new stretch of flex pvc to fix an earlier leak, replaced my jet pump’s wet end, but now . . . I found another leak. This one is right at the base of where a piece of flex pvc enters a 4-way junction (“manifold”?). Based on the location (rear right of the spa) and the number of pipes I assume this feeds the four precision jets located just above the moto massager. Unfortunately I do not think there is any un-broken flex pvc near the base onto which I could cement a fitting. So what
  18. I have a 2001 Hot Spring Sovereign. My heat wasn't working, so I just replaced the heater relay board with the new 77119 part for the IQ2020. Now I have heat and circulation, but the jets stopped working (wavemaster 7000 ver3). They were working previously, but do not anymore. The jet icon lights up on the control head, but no jets. Any ideas? What could I have done in replacing the heater relay board that affected the jets? Thanks, Ben
×
×
  • Create New...