Jump to content

Search the Community

Showing results for tags 'dimension one'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 4 results

  1. We recently got a used Dimension One, Amore Bay spa. When we fill it, water starts leaking from the ozonator. We just purchased a new ozonator, and that one is also leaking. Not sure if we are doing something wrong, or the part was bad. I am attaching a video, don’t mind me talking. The company is sending out a new part. Any help is greatly appreciated! 34314A11-1903-4494-9683-3A4B133B2C51.MOV
  2. We just got a used 2008 Dimension one California jasper model hot tub. We are new to hot tubs. We ordered new filters and installed them. The tub heats up but we keep getting “Low flow error”. Not sure what is causing this to happen. Just want to enjoy my new spa and we have yet to make it in. Thanks to anyone who can help.
  3. My wife and I owned a D1 Aurora spa for 15 years. Early on, we discovered that she had skin sensititvity issue with most sanitizer systems. I couldn't use the D1 vision (silver ion) system, chlorine, or Bromine without her getting a severe itchy skin rash. I found that I could use Baqua Spa without ussue, and I used it for several years, but it was a pain in the butt, and caused other issues. About 8-9 years ago, I tried Pristine Blue (copper sanitizer system) and it was the answer to all my problems. I could maintain crystal clear water without using any chlorine (I used only the monopersulfate shock ans pristine Blue). The D1 had a 24 hour 10 GPM circulation pump and UV type ozonator that ran 24/7 (it didn't shut off when the tub was in use). About two years ago, I started having water clarity issues and found out the UV bulb in the ozone generator had failed. I replaced the bulb and the water cleared up immediately. Fast forward .. The D1 developed a leak that could not be repaired, so we decided it was time to buy a new spa. There is no D1 dealer near us, so we shopped around and bought a Bullfrog Spa about two months ago. The Bullfrog is eqipped with a programmable 35 GPM circ pump and plasma discharge ozone generator. I have set the circ pump to run 24 hours per day, but it only runs about 18 hours per day (probably due to the fact that it is a 35 GPM pump and overheats the water). My issue is that I can't seem to keep the water clear. It reminds me of the D1 with a bad ozone generator. I have to use large doses of chlorine shock several times a week, and monopersulfate shock every day. My wife can't get in the tub for 24 hours after a dose of chlorine shock, and she now takes a shower after every hot tub use (she still has small outbreaks sometimes, despite the precautions). It still often goes from clear to cloudy overnight, and tends to foam a lot as though there are soaps / detergents in the water. We wash all swim suits in the washing machine without detergent to prevent soap in the spa, so that shouldn't be a problem. We are becoming frustrated and begining to wonder if we made a bad decision. We were happy with the D1, maybe we should have bought another one instead of the Bullfrog. The only difference I can see is the circ pump / ozone system design: The D1 has a system whereby the ozone is mixed with the water in a seperate chamber and fully consumed before the water is re-introdued into the tub so that the ozone can run even when the tub is occupied. The D1 used a UV ozone generator and the Bullfrog uses a plasma discharge generator from Del Ozone The D1 had a 10 GPM pump that never shut off. Has anyone else experienced similar issues? Is the UV generator better? I never smell ozone, even when the generator and pump are running, is it possible that the generator is not working? Any help would be appreciated.
  4. I bought a used Spa and somewhere in the transporation I did something. Inside the cover there is a hose that has a Stainless steel mesh cover which I figure is the air intake for the jets well there is a leak coming from outside this pipe not in, but outside. So 1 where could I get a schematic for this model (Nautilus) by Dimension One or does someone have any Idea as to what is happening. Thanks
×
×
  • Create New...