Jump to content

Search the Community

Showing results for tags 'control panel'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 9 results

  1. I have a 2000 Sweetwater Palermo spa. The water temperature is 3 degrees lower than the digital readout on the display on my control panel. (the temperature from a thermometer of the water reads 97 degrees but the display reads 100). I have a new heater, new filter and recently changed the water. I've had this spa since 2000 and am very familiar with how it heats and this is really not normal for the spa. Any clues what the issue might be? Sensor, topside control panel, etc.? Thanks.
  2. I bought an Atera Swim Spa in 2014. No issues. The company was a family owned business AZ. They sold in Dec 2018 to a company in TN. I am having outside control panel issues, I can't get the temp to lower. New company is ZERO responsive. Any info on how I can find a different controller? Will need to control jets, lights and temp. Thank you. Frustrated in AL. Jeanette
  3. I have an old hot tub that is nameless. It has a Baker Hydro Spa Pack model S7A Econo Catalina. Catalog-ABC2250 with serial # 84177. Top-side dual air control made by Len Gordon. Can you recommend an upgrade replacement package?
  4. Looking for advice, my control panel on the J-480 (model year 2012) needs to be replaced and a dealer/repair shop quoted $1,380 just for the panel. Can someone confirm that this is a reasonable price and if not, what would be reasonable?
  5. Any suggestions how to resolve a non responding temperature heat button on a Sundance Caprio? - I found the spa set at 40 deg C (104 F). I turned it down to 34 deg C (93 F) as it was not being used. Some days later when we sought to turn it up to 37 deg and the heat button did not respond in any way. The cool button responds and I was able to reduce the display temperature to 18 deg C (64 F) which was strange as it always stopped at a minimum of some 33 deg C. I cannot raise the temperature display from 18 which it reads when the cool button is pressed only. The little red light is inactive a
  6. hello, I have a Nordic Sport hot tub. I believe 2002. The control panel will go dim and when it does the only button that will work is the Temp Up button and it is what will turn the jets off and on. When it is normal lit the correct buttons do the correct functions. So you can't control the temp or light when it is dim. If the power goes out or your reset the power box it resets the temp back to 95. I also have noticed it is getting stuck on low jets and not turning off after the 20 minutes of circulation. Any thoughts on how to correct these problems. Thank you.
  7. New to this forum. I have a 2013 Hot Spring Limelight series hot tub which I have had zero issues with until recently. I noticed the display letters/numbers started flickering and going off and on intermittently. Luckily, I was able to turn off the pumps and lights before the control head totally died! I removed the panel from the tub body and disassembled it, only to find that the silicon pad (3 buttons) on the left side which controls the jets and "mode up" and "mode down" settings was cracked around the base, allowing water to penetrate into the head and drip right onto the circuit board.
  8. I inherited a nice little spa that has a nu-wave a24 control pack. It has run great, and since I only use it once or twice a week, I keep the temperature turned down by way of the control panel, and then turn it up a few hours before I need it. I went out last night to use it and was surprised to find that the control panel said it was at 101 degrees very quickly but when I felt the water, it was only luke warm. I'm guessing the thermostat has gone bad, but what do I know. I shut it down and when I restored power today it immediately read 90, which of course was wrong. Any ideas before I go re
×
×
  • Create New...