Jump to content

Search the Community

Showing results for tags 'control board'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 6 results

  1. Hello, I have an IQ 2020 control board that I am trying to replace for my Watkins Prodigy hot tub. My current IQ 2020 has the label that reads Watkins PN: 0974201 REV C. I found an IQ 2020 control board with PN: 1302501 REV F. Does anyone know what the difference is between these two IQ 2020's and will both work on my hot tub???
  2. I have a Limelight Flair (FLR1R3307) with a bad topside control board. If I replace it with part #76845, will it work as is or will it require some sort of software update?
  3. Hi I'm new here . But I was wondering if there was somebody I could answer a couple questions for me. I have an older coast ball with the TSPA1 board. As you know most of these boards have been discontinued and I was wondering if it would be a viable option to just replace the whole spa pack with something new or even a different brand or if you would just recommend sourcing out a replacement board as I'm pretty sure mine Is in need of replacement. If a new spa pack is in order what do you recommend ? I was looking at a BP 501 retrofit kit because I like the Wi-Fi feature. And was wonderin
  4. I have a problem with my spa pump tripping the 50amp GFCI breaker. I have been through everything I can think of with this spa. It has 2 2 speed pumps, one which connected to the filter and heater (pump 1) and one that is attached only to some jets (pump 2). Both pumps are identical, new 2 speed 240V pumps. I have also recently replaced the heater, ozonator, and GFCI breaker. I have a Balboa MAS225 control board. Pump 1 runs on schedule because it is used to filter and heat, it comes on as soon as the hot tub is started up (breaker turned on). Pump 2 only comes o
  5. New to forum. I have a 2004 Gr. Lakes Sunlighter I picked up from Craigslist a few years ago. I am running it on 240v. I replaced the heater element about 18 months ago. Been running trouble free since. My pump just started cycling on and off. It starts for just a few seconds, then stops for a second,then continuously repeats. I can hear a relay cycling in the control box. If I hold down the temp setting button on the control panel it stays on. While running the suction/flow are fine. It is a Balboa control system P/N 52525-04. I'm guessing the temp sensor or something related is the issue.
  6. Just recently purchased a Used 05 Artesian Antigua Spa. When I started up tub (a few days ago) the water temp has been stuck on 95 the entire time. U can adjust the water tempature and the other night when it was aabout 55 out I had tub at 95 and tub was about 106 next day set at 85 had temp at 95 now it is 45 out and water temperature is 85 no matter what I set tempature too. Im assumming heater is fine and that my issue is with a limit, relay, thermostat, or contol board. Someone that can lead me in the right direction would appretiated. Thank you for your time.
×
×
  • Create New...